Laptop screen is 144hz but the second (180hz) monitor is 60hz

Hello, i have 2 screens: Laptop built-in screen, that works perfectly with 144hz, and a second monitor with max refresh rate 180hz, but the problem, it’s not like 180hz, it’s very similar to 60hz, but when I switched to xorg, 180hz worked fine, but at the same time I want to use wayland, is it possible to do this?

Right now im using KDE with Wayland, with latest nVIDIA drivers installed (NVIDIA-Linux-x86_64-550.54.14)

My system information:

  Kernel: 6.7.5-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-14.fc39 clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.7.5-200.fc39.x86_64
    root=UUID=6b3dc33d-25c2-49e6-a39e-0e1da069913b ro rootflags=subvol=root
    rhgb quiet rd.driver.blacklist=nouveau nvidia-drm.modeset=1
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland with: krunner vt: 4 dm: SDDM Distro: Fedora
    Linux 39 (KDE Plasma)
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F17 FX707ZC_FX707ZC
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX707ZC v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: FX707ZC.316
    date: 05/03/2023
  ID-1: BAT1 charge: 45.9 Wh (100.0%) condition: 45.9/55.9 Wh (82.1%)
    volts: 17.1 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: full
  Info: model: 12th Gen Intel Core i5-12500H bits: 64 type: MCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x430
  Topology: cpus: 1x cores: 12 smt: disabled cache: L1: 1.1 MiB desc: d-8x32
    KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB
    L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 1131 high: 2815 min/max: 400/4500:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 2815 4: 1725
    5: 1322 6: 400 7: 2301 8: 875 9: 400 10: 400 11: 2144 12: 400
    bogomips: 74649
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    off: HDMI-A-1 empty: DP-3,eDP-2 bus-ID: 01:00.0 chip-ID: 10de:25a2
    class-ID: 0300
  Device-3: Logitech Webcam C310 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:4 chip-ID: 046d:081b
    class-ID: 0102 serial: <filter>
  Display: wayland server: v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: nvidia gpu: i915,nvidia
    d-rect: 3840x1080 display-ID: 0
  Monitor-1: HDMI-A-1 pos: primary,left res: 1920x1080 size: N/A modes: N/A
  Monitor-2: eDP-1 pos: right res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
    surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
    inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.3.5 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a6 memory: 30.24 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.268 layers: 10 device: 0 type: integrated-gpu name: Intel
    Graphics (ADL GT2) driver: mesa intel v: 23.3.5 device-ID: 8086:46a6
    surfaces: xcb,xlib,wayland device: 1 type: discrete-gpu name: NVIDIA
    GeForce RTX 3050 Laptop GPU driver: nvidia v: 550.54.14
    device-ID: 10de:25a2 surfaces: xcb,xlib,wayland device: 2 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.5 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:2291 class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-4.1:5 chip-ID: 0951:16a4 class-ID: 0300
    serial: <filter>
  Device-4: Logitech Webcam C310 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:4 chip-ID: 046d:081b
    class-ID: 0102 serial: <filter>
  Device-5: ASUSTek C-Media Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-9:12
    chip-ID: 0b05:6205 class-ID: 0300
  API: ALSA v: k6.7.5-200.fc39.x86_64 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
  IF: eno2 state: down mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet driver: cdc_ncm type: USB rev: 3.2
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.3:3 chip-ID: 0b95:1790
    class-ID: 0a00 serial: <filter>
  IF: enp0s13f0u1u3c2 state: down mac: <filter>
  Info: services: NetworkManager,wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:13 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 3.19 TiB used: 1.44 TiB (45.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 28.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3B4QFXO7 temp: 35.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.0
    spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5400 serial: <filter>
    scheme: MBR
  ID-1: / raw-size: 475.35 GiB size: 475.35 GiB (100.00%)
    used: 25.17 GiB (5.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 366.9 MiB (37.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 19 MiB (3.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-4: /home raw-size: 475.35 GiB size: 475.35 GiB (100.00%)
    used: 25.17 GiB (5.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    comp: lzo-rle avail: lzo,lz4,lz4hc,842,zstd max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 3000
  Memory: total: 32 GiB note: est. available: 30.97 GiB used: 4.91 GiB (15.9%)
  Processes: 403 Power: uptime: 12m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend,
    test_resume image: 12.35 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 254 target: graphical (5)
    default: graphical tool: systemctl
  Packages: 28 pm: flatpak pkgs: 12 pm: snap pkgs: 16 Compilers: gcc: 13.2.1
    Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33

Удалил(а) audio, bluetooth, flatpak, pipewire, server

Please show us the output of dnf list installed \*nvidia\*. It appears that is actually the release for nvidia that is currently in rpmfusion-nonfree-updates-testing. As such it is still a testing version of the driver and you did not tell us if it worked properly with the stable 545.29.06 driver version.

I do not have a monitor to test your config, but it seems this may be a wayland issue since it works properly with xorg. Possibly this should be reported as a bug with wayland and the nvidia drivers. The nvidia drivers and xorg work as expected, but nvidia drivers and wayland do not.

nvidia-gpu-firmware.noarch                                       20240220-1.fc39                                          @updates
nvidia-persistenced.x86_64                                       3:545.29.06-1.fc39                                       @rpmfusion-nonfree-nvidia-driver

I followed this tutorial to install nvidia proprietary drivers: Fedora 39/38/37 NVIDIA Drivers Install Guide [550.40.07 / 545.29.06 / 535.154.05 / 525.147.05 / 470.223.02 / 390.157 / 340.108] :: If Not True Then False

I also started glxgears to look at refresh rate, and it shows only half of refresh rate

I did a little digging and realized that it is VSync that is limiting my monitor, but I cannot turn it off in the settings (there is simply no such option)

That is from INTTF and is not one that I personally ever recommend. While it may be a perfectly valid source and work well for some there are others for whom it does not work.

What I always recommend is to remove all nvidia drivers that have been installed from another third party source then install the nvidia drivers from the rpmfusion site only. The nvidia drivers from rpmfusion are tweaked and tested to function properly on fedora while drivers from any other source must be tweaked by the user. If you are not experienced in that area then it becomes a problem.

You might note that the only rpm for nvidia that is currently installed on your system is the nvidia-persistenced package.

My strong recommendation.
Remove the currently installed nvidia drivers then install the drivers from rpmfusion with a simple command sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda then wait 5 minutes before you reboot. I cannot tell you how the removal is to be done but it usually is exactly opposite the way the installation was done.

akmod-nvidia.x86_64                                                     3:545.29.06-3.fc39                                @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.7.6-200.fc39.x86_64.x86_64                                3:545.29.06-3.fc39                                @@commandline
nvidia-modprobe.x86_64                                                  3:545.29.06-1.fc39                                @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                                              3:545.29.06-1.fc39                                @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                                  3:545.29.06-1.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                              3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                                         3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686                                      3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                                    3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                                      3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                                           3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                         3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                                        3:545.29.06-2.fc39                                @rpmfusion-nonfree-nvidia-driver

I installed this drivers, but it didnt help, and thats okay if dont see my monitor in nvidia-settings?


That may require that you explicitly select the desired refresh rate from the gnome Settings → Display control panel. Each monitor can be configured independently there.

There also is an update for the nvidia drivers in the rpmfusion-nonfree-updates-testing repo that is currently being tested and should soon be pushed to the repo you used. I don’t know that it will affect individual monitor refresh rates since that is usually set within gnome settings panel.

The update does add additional features to the nvidia settings panel.
There also is a difference in what settings are available when running an xorg DE vs. the wayland DE.

This image is when using Wayland

This image is when using xorg – Notice the difference in the left column.

My monitor is LG brand will limit itself to 60Hz if I use a HDMI cable can only get 144 and up with a Display Port Cable.