Lack of icons in Files, no X11/Wayland/etc. options on login screen, other visual problems

I did a clean install of 40 on a laptop with AMD graphics. Works great so I did a dnf install on a desktop with a NVIDIA NVS 510 graphics card. In Files, folder icons show plus one or two others, but most individual files don’t show an icon and previews are non-existant if I switch from list view.

In the Software installation GUI, icons appear but words only appear if I pass over them with the cursor or start to scroll. The featured software at the top never has a name, only the icon.

The graphics setting icon on the login screen also never appears so I’m unable to choose the windowing system.

None of the above was a problem in 39 and I regret upgrading.

Added gnome-software, nautilus, x11-wayland-transition and removed amd

Hi, so several issues here. Mixing up stuff like AMD and NVIDIA does not help, if you only have problems on one install.

try to install sushi, the nautilus previewer. It is available from the Fedora repos, and from Flathub.

This should be preinstalled, if it solves the problem. If it does, please file a bug here that sushi should be included in Workstation.

That sounds horrendous. Do you only have this on the NVIDIA system? Is the other one also with F40 or with F39?

That’s odd, because even Wayland-only, there should be the GNOME Classic session available.

Also odd as the GNOME edition / “Workstation” still has X11 preinstalled

I included the comment about 40 working on the laptop with AMD graphics to indicate that the problem is likely related to the graphics card. None of the problems mentioned appear on the AMD system with 40 installed, only on the NVIDIA system.

Sushi is already installed. The current windowing system is X11.

Have you installed the rpmfusion nvidia drivers?

I am not sure if the NVS 510 gpu is supported by the latest drivers. According to the nvidia site it uses the 470 driver, which may limit you to only running X11 and not wayland since the 470 driver does not support wayland. I am not certain exactly which GPU chipsets are the cutoff for that driver. The 470xx driver can be installed as akmod-nvidia-470xx from the rpmfusion-nonfree repo after enabling that repo as shown here.

Everything under Maxwell. . . So the 750ti ( is Maxwell ) and the weird Laptop series ? Maxwell GTX9XX. Not the GTX7XX and Fermi etc. So OG Titan is also gone.

Yes, I have. Sorry, I should have mentioned that.

Sorry, trying to figure out how this forum works still. I have the rpmfusion driver installed, always have. And in the past I have used Wayland on this computer. I think X11 is my current windowing system because that was probably what I was using when I did the upgrade.

I also went to NVIDIA’s site to see if there was a more up to date driver. I followed their prompts and ended up downloading a run file. I ran it, but it failed in the end. I don’t recall why.

I checked my version number in Terminal. It’s 470.256.02

Using the .run file directly from nvidia works for some but is generally discouraged since the packages installed from rpmfusion are tweaked and tested to function on fedora. Very few have problems with them.

Please provide the output of dnf list installed \*nvidia\* so we can tell what exactly you have installed.

I tried to copy here the resulting list but I kept getting an error message saying new users can only mention two users in a post. I didn’t mention any. If anyone knows a way around this I’ll happily comply.

Post the output as preformatted text using the </> button I think will stop that error.

Question: when you’re logged in, do the visual issues appear both to gtk4 apps (e.g. Files, Settings, Calendar) as well as legacy gtk apps (e.g. Document Viewer, Terminal) , or is it only with gtk4 apps?

If it is only with gtk4 apps, then it might be GTK’s new GL (ngl) renderer, and there is a fix too.

akmod-nvidia-470xx.x86_64                      3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-470xx-6.9.6-200.fc40.x86_64.x86_64 3:470.256.02-1.fc40 @@commandline
kmod-nvidia-470xx-6.9.7-200.fc40.x86_64.x86_64 3:470.256.02-1.fc40 @@commandline
nvidia-driver-NVML.x86_64                      3:555.42.06-1.fc39  @cuda-fedora39-x86_64
nvidia-driver-cuda.x86_64                      3:555.42.06-1.fc39  @cuda-fedora39-x86_64
nvidia-driver-cuda-libs.x86_64                 3:555.42.06-1.fc39  @cuda-fedora39-x86_64
nvidia-persistenced.x86_64                     3:555.42.06-1.fc39  @cuda-fedora39-x86_64
nvidia-settings-470xx.x86_64                   3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx.x86_64               3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64       3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-libs.i686            3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-libs.x86_64          3:470.256.02-1.fc40 @rpmfusion-nonfree-nvidia-driver

The issues do not appear in Settings (or at least I haven’t run into problems yet), but it does in Files, Software, Calendar and, as I wrote earlier, I don’t get the icon for the windowing system choice on the login screen. I don’t have problems with Document Viewer or Terminal.

Because I occasionally need the document preview icons in Files (Nautalis, right?), I installed Dolphin and have no issues with that file system viewer. So I am inclined to think the problem is related to Gnome’s dealing with this Graphics card.

I had a similar issue when upgrading to F40 on an old system, and got it solved by reverting to the old gl renderer. See original solution here:

I ran echo “export GSK_RENDERER=gl” > /etc/profile.d/ as recommended in that post, but the reply was “bash: /etc/profile.d/ Permission denied”. And, yes, I did use sudo so I’m not sure how to get permissions to run it.

Yes, in the post I shared it is missing the info that the /etc/profile.d/ file should have been created first.

Do that and then run the echo command, or put the instruction directly in the file created with the text editor of your choice. Reboot the system.

Being very much an amateur at these things, it took me a bit to get my head around this, but I finally did and it resolved 99% of the problem. The only thing that still isn’t working right is the lack of the icon to change the windowing system in the login screen. Presumably that is a separate problem, or it could just be that the file just created doesn’t load until after the login.

1 Like

Sudo to a root shell, then execute the command. /etc/profile.d needs root privilege to write into it.