KRunner freezes after a while

Hello all!

I fairly recently changed from Manjaro KDE to Fedora KDE on my laptop (still running Manjaro on stationary computer). I installed f36 during the autumn 2022, a few weeks before the f37 release. I then upgraded to f37. Most of the stuff is working great, but I’m having issues with KRunner (alt+space).

Sometimes, seemingly random KRunner just refuse to accept any input. I can open it with the shortcut, but then I can’t write any text into the textfield. It also doesn’t respond to , which normally closes KRunner. If I use the to open up the Application Launcher KRunner is closed, but if I open it up again it is still the same. I can fix it by opening the Systemmonitor and “End process” on KRunner. It immediately starts responding, i.e. I don’t have to restart the process or anything, it just starts working without any noticeable changes.

I have never experienced similar issues in Manjaro KDE even though I have been running it for a few years.

As of now I haven’t kept detailed track on my activites so I can’t narrow it down. I was hoping someone else have experienced it before. If not I will have to do my best in narrowing down possible causes.

Have anyone else seen anything similar or do anyone know how to troubleshoot further?

  Host: fedora Kernel: 6.1.6-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.5 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: LENOVO product: 82AC v: Yoga Slim 7 15ITL05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: FBCN21WW date: 11/09/2020
  ID-1: BAT1 charge: 64.0 Wh (99.8%) condition: 64.1/71.0 Wh (90.3%)
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 1155 min/max: 400/4700 cores: 1: 1120 2: 1201 3: 1104
    4: 1201 5: 1114 6: 1145 7: 1201 8: 1159
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.7
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 resolution: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: Mesa Intel Xe Graphics (TGL GT2)
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  Sound API: ALSA v: k6.1.6-200.fc37.x86_64 running: yes
  Sound Server-1: PipeWire v: 0.3.64 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi
  IF: wlp0s20f3 state: up mac: fc:b3:bc:77:b5:5a
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 18.76 GiB (2.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HBLR-000L2
    size: 953.87 GiB
  ID-1: / size: 952.28 GiB used: 18.46 GiB (1.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 274.5 MiB (28.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 33.4 MiB (5.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 952.28 GiB used: 18.46 GiB (1.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 403 Uptime: 3h 38m Memory: 15.42 GiB used: 7.61 GiB (49.3%)
  Shell: Zsh inxi: 3.3.24

Welcome to the fedoraproject @golgor

Try to log in in X11 session instaed of Wayland to see if this changes something.

Here are some additional changes you could try to let it work Wayland too.

KRunner - ArchWiki

Awesome, thanks a lot ! I have been testing with X11 for a few days and it seems to work fine. I haven’t been using the computer as much though, so i will let keep going with X11 for a couple of more days.

I will also look into the link you sent!

This did seem to be an issue with Wayland. I have been running with X11 now for several days and I haven’t had any issues at all. Still not sure how to debug it. I guess i will stay with X11 for a while now.

Are you shure you also used wayland with Manjaro? Did you have no issues with the same Hardware?

  • Bring your system up to date
  • check on a running system without errors the versions of dnf rq --whatprovides APPNAME and compair with the buggy one.
  • Reproduce the error and then check with
  • journalctl |grep -i APPNAME

before you file a bug you could show us the result of the journalctl command. Might be if someone sees something more we not discussed yet. >>

Please read the document below. The link above is a shortcut to check if already filed a bug for the desired application (/krunner=desired app)