Kinoite sddm fails with nvidia-container-toolkit installed

I’m running Kinoite F38 on my System76 laptop. I recently needed to install (as a layered package) nvidia-container-toolkit to build a couple containers for running machine learning code on my gpu. I’m also using akmod-nvidia.

After installing and rebooting, when I try to log into KDE (X11) via SDDM the screen goes black for about 20 seconds then kicks me back to the SDDM login screen again.

I can login to KDE Wayland, I would prefer to use that but can’t for other reasons outside my control atm.

If I run startx from a tty without SDDM running I get a somewhat usable KDE instance.

This only seems to happen if I have external monitors plugged into my laptop (the hdmi port is hardwired to the gpu). If I try to login with no external displays plugged in KDE loads just fine. Interestingly, I can then plug my monitors in again and everything works correctly. I have not tried logging out and logging back in after reconnecting them.

I did have this working at one point, after running a cleanup job with rpm-ostree, but I did an update yesterday and now it’s happening again.

I’ve also tried installing lightdm and lxdm to see if the issue is specific to sddm, but neither will actually start.

I’m not sure where to look next to troubleshoot this issue. Anyone have any thoughts or tips here?

UPDATE: I just uninstalled nvidia-conatiner-toolkit and installed nvidia-container-toolkit-base, which is all I actually need. It still exhibited the same behavior as mentioned above.