Can't login on Kinoite 38

A few months ago I started having to select my keyboard layout (Norwegian) in SDDM on every login, because it defaults to US.

Three-four weeks ago I could no longer log in without typing the username in SDDM manually. Typing the correct password for the default user failed, while if I typed the username manually it succeeded.

Two-three weeks ago I could no longer log in using SDDM at all. Every password, username and keyboard layout returns “login failed”. Login with TTY works.

Since then I tried hopping to Sericea (which I’ve got comments on regarding the default applications…why not all wayland native?), Silverblue (I couldn’t get used to the hotkeys and limited settings options, and mouse centric UI irks me), in both Fedora and Ublue.

Now I want back to my familiar Kinoite.
I tried rebasing to Kinoite 38 from Fedora again, but the SDDM issue persists.

Typing this from my phone, so no logs yet unfortunately, but once I get a tty and rebase onto something working I’ll get a journalctl -b 1 up

Short term workaround: try going back to SDDM in X11 mode:

  1. Write the following content into a file named /etc/sddm.conf.d/x11.conf:

  2. Reboot

(From Changes/WaylandByDefaultForSDDM - Fedora Project Wiki)

Ay it works!
This will last me until a more permanent fix is made.

This might be related to Listed language on the login screen is wrong · Issue #1767 · sddm/sddm · GitHub

As of Kinoite 2023.10.10, the SDDM wayland backend works perfectly for me :smile: