Sddm white screen and forced login

I installed KDE Plasma Workspace with a Fedora 37 network installation on my System76 Gazelle a few months ago (dual-booting with Pop!_OS on a separate SSD). I’ve had a number of issues with KDE which I won’t go into here, and although I’ve also installed Xfce, I can’t switch to it because sddm no longer gives a selection for user or session – it comes up with a white screen that has a password prompt in the center. From there, I can successfully log in as that one user, but logging out or re-booting just brings me back to the white password screen.

I’m not familiar enough with sddm to know how to troubleshoot this. FWIW, I’ve tried clearing out /var/lib/sddm/, but that hasn’t helped. Google hasn’t helped find anyone reporting this issue.

Not sure it matters, but the session that starts appears to be Wayland rather than X. Also, I originally configured the machine in “hybrid” graphics mode (nVidia + Intel graphics) but later switched to Intel-only. I don’t remember when this symptom started, so I’m not sure whether there’s any correlation between them. I’ll try switching back to see if it makes a difference.

  • Don

This definitely sounds like it might be graphics related. If one has both nvidia and intel GPUs the best option is to always have drivers loaded for both, even if only one is used. Strange symptoms may appear with hardware that has no driver since one does not know what may trigger a response from the device.

I switched it back into hybrid graphics mode (and rebooted), but the symptom is still the same. lsmod shows that both nouveau and i915 (I assume this is right for the on-chip GPU in i7-12700H) modules are loaded. I haven’t noticed any other strange issues with graphics, before or after the mode change.