Keyboard latency with Logitech G915 wireless keyboard

Hi all, i’ve recently installed F34 on bare metal dual boot with win 10. I’ve noticed that I’m getting some lag (just enough to catch me out and to be irritating, but not enough to stop me using it as a daily drive).

I’m using the default gnome desktop, and i’ve not installed any special drivers.

I’m using the “lightspeed” dongle to connect which is fine under windows, but I can really feel it under linux.

I really want to use this as an opportunity to learn how to troubleshoot these kind of issues, can anyone point me in the right direction ?

I did see on a previous post someone aksed to run the command, however I was unsure how to decode it.

Any pointers (even just to documentation) would be really appreciated. Thank you!

inxi -Fzx #shows systeminfo
$ inxi -Fzx #shows systeminfo
System:    Kernel: 5.14.12-200.fc34.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35.2-6.fc34 Desktop: GNOME 40.4 
           Distro: Fedora release 34 (Thirty Four) 
Machine:   Type: Desktop System: Gigabyte product: X570 AORUS MASTER v: -CF serial: <filter> 
           Mobo: Gigabyte model: X570 AORUS MASTER v: x.x serial: <filter> UEFI: American Megatrends v: F30 date: 09/07/2020 
CPU:       Info: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 type: MT MCP MCM arch: Zen 2 rev: 0 cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 224020 
           Speed: 2055 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz): 1: 2055 2: 2057 3: 2198 4: 2205 5: 2200 
           6: 2200 7: 2199 8: 2199 9: 2053 10: 2056 11: 2056 12: 3598 13: 2051 14: 2199 15: 2198 16: 2200 17: 2198 18: 2202 
           19: 2200 20: 2197 21: 2202 22: 2200 23: 2200 24: 2195 25: 2200 26: 2197 27: 2198 28: 2200 29: 2212 30: 2195 
           31: 2198 32: 2192 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: Gigabyte driver: nouveau v: kernel bus-ID: 12:00.0 
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 9- 
           Display: wayland server: X.Org compositor: gnome-shell driver: loaded: nouveau 
           note: n/a (using device driver) - try sudo/root resolution: 3840x2160~60Hz 
           OpenGL: renderer: NV164 v: 4.3 Mesa 21.1.8 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 12:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 14:00.4 
           Device-3: Solid State Logic SSL 2+ type: USB driver: snd-usb-audio bus-ID: 13-6.1:5 
           Device-4: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 9- 
           Sound Server-1: ALSA v: k5.14.12-200.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 0b:00.0 
           IF: wlp11s0 state: up mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: e000 bus-ID: 0c:00.0 
           IF: enp12s0 state: down mac: <filter> 
           Device-3: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 0d:00.0 
           IF: enp13s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 13-5:3 
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
Drives:    Local Storage: total: 15.92 TiB used: 6.15 TiB (38.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB temp: 49.9 C 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB temp: 40.9 C 
           ID-3: /dev/sda vendor: Samsung model: SSD 860 EVO 2TB size: 1.82 TiB 
           ID-4: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A3 size: 12.73 TiB 
Partition: ID-1: / size: 1.82 TiB used: 7.98 GiB (0.4%) fs: btrfs dev: /dev/sda3 
           ID-2: /boot size: 975.9 MiB used: 233.9 MiB (24.0%) fs: ext4 dev: /dev/sda2 
           ID-3: /boot/efi size: 598.8 MiB used: 16.2 MiB (2.7%) fs: vfat dev: /dev/sda1 
           ID-4: /home size: 1.82 TiB used: 7.98 GiB (0.4%) fs: btrfs dev: /dev/sda3 
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 41.2 C mobo: 16.8 C gpu: nouveau temp: 31.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 776 
Info:      Processes: 522 Uptime: 38m Memory: 62.71 GiB used: 3.41 GiB (5.4%) Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 
           Packages: N/A note: see --pkg Shell: Bash v: 5.1.0 inxi: 3.3.06 

I do use a K220 from Logitech and i had a similar situation when i used it with the Smart TV. The Usb connector was behind the TV and i had to use an USB extension to bring the dongle away from the backside of the TV. As soon as i made this the lag was gone.

I guess first you could do this that you have no obstacles between the dongle and the keyboard, even if it works with windows.

1 Like

Lol, I hear you :slight_smile:

So I have the pleasure of a day off from work, and I’ve tested the keyboard on the actual console (outside of GNOME and any kind of X (showing my age there)). It appears the console is fine there is 0 latency, so I’m now working on the assumption that it’s not hardware related but more to do with the way gnome (or any kind of desktop) interacts with hardware. It’s not something I know much about so a great chance to dive into the rabbit hole.

Just a reason I think this is important (apart from my own OCD triggering every time I type) is that this is potentially something that will impact a user consiciously or subconciously when using Gnome. The old “It feels slower than windows”.

I’m not trying to pull anyone else in, and i’ll share my expriences trying to debug in this thread.

Thanks for all your help so far!

So I’m feeling a little bit daft. It looks like it was actually a delay only in google chrome, and caused by the “hardware acceleration” option. I’ve disabled it, and things seem much faster.

For anyone with the same issue…

Chrome → settings → advanced → system → enable hardware acceleration → disable.

Thanks all.