Kernel-headers-5.4.8-200.fc31.x86_64, does it exist?

I am running Fedora 31, on kernel ‘5.4.8-200.fc31.x86_64’. I’m trying to get VirtualBox working, and here’s the old classic… the kernel modules won’t compile. I installed kernel-headers, kernel-devel, elfutils-libelf-devel, etc. Still won’t compile since it can’t find the headers. I was confused because I had installed them. I double-checked, and the version it installed was slightly different.
Kernel: kernel-core-5.4.8-200.fc31.x86_64
Headers: kernel-headers-5.4.7-200.fc31.x86_64

I double-checked the dnf repo, and they’re not there. Googled the internet, but no joy. So the question is, does a kernel-headers package exist for 5.4.8-200? If not, how do I get those kernel modules to compile?

Welcome to Fedora, @midnight1. Please take a minute to look at the posts in the #start-here category if you’ve not had a chance to do so yet.

As said by @chrismurphy in this post:

I’m pretty sure kernel-headers is only built/rebuilt when the interface between kernel and userspace changes, which doesn’t happen every dot version.

Said that, how are you installing VirtualBox? By downloading the RPM package from virtualbox web site or from the RPMFusion repository?

1 Like

I downloaded it from the Virtualbox website. Then I did a ‘dnf localinstall’ on that rpm.

Install went fine. No issues at all. Program runs, and allows me to create a new virt machine. It just fails on start of that virt system because the kernel modules weren’t able to be compiled.

Did your tried Gnome-Boxes?

1 Like

Nope. I need to get VirtualBox working. VMware Player is a second choice, but it has the same issue. Uncompiled kernel modules.

Mark as solved!

Found a great guide here that solved my issue. Modules compiled properly this time. :slight_smile:

1 Like

Hello @midnight1 …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

you don’t need to edit your post as solved, just use the function the site provide for that purpose:



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.