Kded5 asks for kdewallet password

I just upgraded to Fedora 34 from Fedora 34.
A problem that I encountered was that after I logged in, a window pops up and says that “kded5 asks for kdewallet password” (or something close to this).
I have read about this but the prompts should appear when you have auto-login active, which I don’t.
So, does anybody have an idea as to why isn’t the kdewallet unlocked when I log in?
Thank you!

same problem here
on my end I tracked it down to being caused by NetworkManager trying to get the password for the WiFi network

Yeah it’ll be a pam configuration issue somewhere probably or that the kwalletmanager is not tying into the system login properly. Happens on a clean install of Fedora 34 too. But after looking into it further, I found that you need to ensure that pam-kwallet is installed and you need to ensure that the following lines are set in /etc/pam.d/sddm:

-auth optional pam_kwallet5.so
-session optional pam_kwallet5.so auto_start

they need to be in the relevant sections of that file (e.g. auth in the section with all the other auth items and session in the section with all the other session items.


Thanks to all above for asking and answering, this helped a lot. I too had this issue on updating to F34 (KDE spin) from F32, and trying Wayland desktop… here are couple more details that may be helpful if you’re newer to Linux:

To edit the file Ryan mentioned above, I ran:

sudo nano /etc/pam.d/sddm

It already contained the lines he mentioned, with the - at the start of them as he shows above. But looking at the other lines in the file, it seemed to me that maybe the - was someone’s idea of a comment symbol in this file, and so it meant these lines were commented out.

I have not searched the web to confirm that theory, but removed the - from each line, saved my changes, and restarted my computer… and on re-entering the KDE desktop, I was not prompted for the password any more, and the system signed on to the WiFi just fine, as it had in F32. So I’ll call that a win.

I hope that helps someone as the other answers here helped me.

1 Like

PAM configuration files use # for comments. The - prefix tells libpam to not log failures caused by that line (e.g. because the module isn’t installed).

I tried reproducing your results, but I’m still prompted for the kwallet password when I login.