Default config of /etc/pam.d/sddm


I just messed up with /etc/pam.d/sddm config file inorder to set up howdy face unlock. Anyone help me by providing the default Config file of /etc/pam.d/sddm

Also help me to know nw where it went wrong.

My present config is

#auth     [success=done ignore=ignore default=bad]
#auth        sufficient /lib64/security/howdy/
auth        substack      password-auth
-auth        optional
-auth        optional
-auth        optional
auth        include       postlogin

account     required
account     include       password-auth

password    include       password-auth

session     required close
session     required
-session    optional
session     required open
session     optional force revoke
session     required
session     include       password-auth
-session     optional auto_start
-session     optional auto_start
-session     optional auto_start
session     include       postlogin

Hi @hemanthch What Fedora Option? In my pam.d no sddm, what app does bring sddm?

You can use the authselect tool to create a new, working PAM stack. It’s likely that sudo authselect apply-changes (which re-writes your currently configured options).

If that doesn’t do it, check the man page for details, or the RHEL 8 documentation, which largely applies. You may find authselect check particularly helpful to start.

I think this will correct the one for sddm (@jpbn, that’s the login/display manager used by the KDE Plasma spin and possibly some other desktops.) If it doesn’t, sudo dnf reinstall sddm should install the “correct” config file (possibly as .rpmnew).


I’m using KDE