KDE: Zoom - Push option has no effect

I am partially blind and rely on Zoom to use my computer and i prefer the cursor to push the screen arround instead of moving along with it. So, Inside Desktop Effects > Zoom i swith Mouse tracking to Push but it has no effect and mouse tracking still works as though its set to proptional. This makes it really hard for me to use my computer.

System Information:
Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.15.17-200.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-6500T CPU @ 2.50GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530

Can you please check if it works with x11 ?!

Is this zoom an app you have to install? I checked on the live iso and could not find a setting to do so.

You might want to take a look at these upstream bugs:


Zoom is most certainly an app, and is used for meetings of many types. It is available from https://support.zoom.us/hc/en-us/articles/204206269-Installing-or-updating-Zoom-on-Linux

@computersavvy I do use zoom.us too. I just cant imagine that he relies on zoom for meetings.

It is about zooming the the screen with cursor. As we would scroll on the screen he likes to zoom alias push with the cursor the content on left, right, up and down ?!

I did check that and when i switch to X11. I cant zoom in it just doesnt work i tried using all the diffrent shortcuts but nothing happens. i verified the settings and they saty athe same. I tried switching Mouse tracking to propotional to see if it helps but of no use. Zoom just doesnt work in X11.
Theres a similar issue with Gnome as well. When i switch cursor to push. Gnome shell automatically crashes if i move my mouse cursor. Thats actually the biggest reason why i switched to KDE.
Check out this Topic -Gnome Shell crashing on Cursor Movement

1 Like

:joy: P.S. I did not mean Zoom as in meeting app I ment as in Zooming the Screen The Accessibility Feature
You could find it under System Settings > Windows Behaviour > Desktop Effects > Zoom

1 Like

Yup I ment Zoom as in the accesebility feature. I cant really see small text or content so i have to Zoom in to view things. The feature keeps track of where the mouse cursor is and moves the zoom focus accordingly by default its set to Propotional by wich as i move the mouse the Zoom focus moves along.
And i prefer push where the focus stays where it is and i could move my mouse cursor within the focused area without shifting or moving the focus. The focus moves when i try to move the cursor outside the focused are like pushing it .

1 Like

Can someone on KDE please confirm this issue?

@falcon-z can you please give steps to reproduce again as you did for the Gnome shell bug (which has been fixed but not released yet)?

I’m afraid this sounds like another bug, but it’ll be good for someone that uses KDE to confirm it first.


  1. Go to System Settings > Workspace Behaviour > Desktop Effects > Zoom
  2. Change Mouse Tracking to “Push”

Which should allow you to move mouse cursor freely within the focused area without shifting focus. The focus should only move as you move mouse cursor across the edge of focused area.

Just a while ago i noticed that this works as intented for a few seconds then starts to work as if Mouse tracking is set to “Propotional” which moves focus along with the cursor as it moves

1 Like

Thanks @ankursinha Hope the fix gets released soon

1 Like

Yeh, hopefully the next release. I guess one could bump the ticket there and request a minor release, or ask the Fedora maintainer to include the patch in the Fedora build?

Dunno about the KDE issue, though. Could be another similar bug :frowning:

Yeah, the sooner the better.i wish these sort of isues get more priority. Accessibility has been a long standing issue in linux desktops its amazing where were right now in terms of desktop environments, usability and User experience but, still there are a ton of bugs and UX issues related to Assistive technologies. With all the advances Linux desktops really fall behind in Accessibility. I wish with all the efforts in the community i hope this wont be the case for the future.
However, DE’s should do more accesebility testing and gather more feedback… If they do i’ll be happy to help out.


Do you want to try filing a bug asking the maintainer to include the patch perhaps (if it doesn’t require them too much work to backport the fixes)?

We do have the accessibility as part of the Gnome test day each release, but I guess not all options get tested or this would’ve been caught before release.


You could also start a discussion with the QA team to improve this test case maybe?

Thanks @ankursinha i will certainly do as u suggested :slightly_smiling_face:

And yes i do want to file a bug for the patch so, could u direct me on how i could do that?

1 Like

Thanks, @grumpey this is exactly the problem i have. However these bugs seems to be associated with older versions of KDE. Is there something i could do ?

1 Like

For the gnome-shell bug, patches are required in mutter and gjs, so you’ll file bugs on bugzilla for each of these requesting the maintainer to include the patches I guess.

Another way would be to speak to the workstation/desktop team here maybe?


For the KDE thing, fresh bugs will need to be filed at the KDE bugzilla :confused:

1 Like