KDE SDDM (login page) locale / time format / touchpad tap-to-click

How can be the the KDE SDDM (login page) changed:

  • locale
  • time format
  • enable touchpad tap-to-click

Is it even possible to change in UI or only editing some .conf?

Region & language (if you type locale in Kickstart launcher) in system settings should apply to KDE SDDM loading the keyboard layout on login session.

You can change /etc/locale.conf. Refer to this user documentation.

About tap-to-click for the touchpad, check this page I recently updated.

Tnx for your reply.

  1. Is there a way to change the region/format for SDDM from UI?
    Seems Linux is still not so used friendly… :frowning: Windows has this setting (not easily to find, but there is one at least).

  2. Sure I found how to enable the double-tap from KDE UI (strange it is not enabled by default, I read it will change in 6.0), but I asked about enabling it for SDDM.

  1. Press Super key and type ‘region’ and select ‘region & language’.
    Click ‘modify’ on the language if you want to change. A change in regional & language will persist after next reboot/login.

  1. I don’t think there is a way to change tap-to-click in SDDM login screen.

Once I set my language and keyboard in settings (which will persist), there is no reason to change it in SDDM.

I’m asking about the “welcome screen” (as I found it’s naming is SDDM).

Sure I changed locale/time in KDE from KDE’s system settings and there all is OK.
But this does not affects the “welcome screen” after boot (since are used default settings from the installer).

When I lock the KDE session I see “welcome screen” with my settings. When I log off from KDE I see default settings. And tap-to-click does not works (since again it is off by default).

There IS a reason for ME (at least) to change the SDDM, since I see a) US time format, that I do not like at all and b) cannot tap-to-click that is ridiculous.

Now, I understand what you experience.

Since last two weeks, I evidenced the same behavior as you described. I removed language selector in SDDM to ignore behavior for now and got carried away for other priorities.

As this thread is tagged # kde, I add kde-plasma for more reach to people in KDE Special interest group.

SDDM isn’t picking up the locale/keyboard layout and tap-to-click set globally.

Please find a thread related to SDDM issue. It is a bug.

It’s not a bug. it’s problem that happens because ssdm does not know user that logins and it captures locales from /etc/default/locale file
so change LC_TIME locale in the /etc/default/locale and all will be fine

Reddit topic that describes it