Issues with Wayland guests on QEMU

I have a couple of issues that are related, so I think it’s best to combine them here. This has to do with VM’s using QEMU with virt-manager.

Host is Fedora Workstation. I’m using the virtio display driver.

When I run a Workstation/Gnome guest, the X11 session performs great. The Wayland session is stuttery, with jumpy cursors and non-smooth window movement. It’s not a usable experience.

When I run a KDE spin as guest, the X11 session performs great. The Wayland session runs just as smooth but does not support capturing the clipboard from my host (yet I am able to drag files to the guest desktop).

Unfortunately, it seems as if using Wayland in a VM is problematic.

I want to use Wayland whenever possible. Does someone have any specific fixes for these issues (Gnome-stutter, KDE-clipboard) or general comments about using Wayland in a VM?

Have you tried using QXL as the video driver?

QXL is for X11, not Wayland. I’m looking for Wayland solutions.

Works for me as you can see from inxi report.

$ inxi -Gbxx
System:
  Host: fedora Kernel: 6.5.6-300.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc v: 2.40-13.fc39
  Console: pty pts/2 DM: SDDM Distro: Fedora Linux 39 (KDE Plasma)
Machine:
  Type: Kvm System: QEMU product: Standard PC (Q35 + ICH9, 2009) v: pc-q35-8.1
    serial: <superuser required> Chassis: type: 1 v: pc-q35-8.1 serial: <superuser required>
  Mobo: N/A model: N/A serial: N/A UEFI: EDK II v: edk2-20231122-14.fc39 date: 11/22/2023
CPU:
  Info: 4x 1-core 12th Gen Intel Core i7-12700K [SMP] arch: Alder Lake speed (MHz): avg: 3610
Graphics:
  Device-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel ports: active: Virtual-1
    empty: Virtual-2,Virtual-3,Virtual-4 bus-ID: 00:01.0 chip-ID: 1b36:0100
  Display: server: X.org v: 1.20.14 with: Xwayland v: 23.2.1 compositor: kwin_wayland driver: X:
    loaded: N/A unloaded: fbdev,modesetting,vesa gpu: qxl tty: 120x36
  Monitor-1: Virtual-1 size-res: N/A in console
  API: EGL v: 1.5 platforms: device: 0 drv: swrast surfaceless: drv: swrast wayland: drv: swrast
    inactive: gbm,x11
  API: OpenGL v: 4.5 vendor: mesa v: 23.2.1 note: console (EGL sourced) renderer: llvmpipe
    (LLVM 16.0.6 256 bits)
  API: Vulkan v: 1.3.250 surfaces: wayland device: 0 type: cpu driver: mesa llvmpipe
    device-ID: 10005:0000
Network:
  Device-1: Red Hat Virtio 1.0 network driver: virtio-pci v: 1 pcie: speed: 2.5 GT/s lanes: 1
    port: N/A bus-ID: 01:00.0 chip-ID: 1af4:1041
Drives:
  Local Storage: total: 64 GiB used: 4.44 GiB (6.9%)
Info:
  Memory: total: 4 GiB available: 3.79 GiB used: 2.08 GiB (54.8%)
  Processes: 250 Power: uptime: 5m wakeups: 0 Init: systemd v: 254 target: graphical (5)
    default: graphical
  Packages: Compilers: N/A Shell: Bash v: 5.2.15 running-in: pty pts/2 inxi: 3.3.33