Issues in all fedora versions

Hi, I’m new here, here is the full summary of my issue:
My pc has a defect which causes it to only detect os when manually added in the file boot menu. I have tried all fedora versions from 35 to 40 nightly.I have tried remaking the efi partition. I’m trying fix this since 4 days. all the other distros like nobara, linux mint, ubuntu and zorin os work fine. the issue is grub cannot detect the fedora os. when I installed fedora 20 days ago it worked but accidently wiped it. I have tried to wipe all things related to fedora and reinstall it. is there a way to make grub detect fedora from a live cd, linux mint or by editing the grub file so that I can manually add the entry for fedora. please answer quick because it is hard for me to dualboot on windows on a hdd. I have tried to directly boot using vmlinuz but it just gives an initramfs error, I have tried rEFIND also. Please give a suggestion that seems to work well and is not too complicated. I have tried reinstalling and manually deleting the fedora efi entry. If you can please also suggests answers from other forums and sources. Here is the link for the video describing the error :!Ao6vb-vAMfBxavV1xgDmi2SdgWQ
I also got another error so when I try to boot another os from the fedora grubx boot menu and shimx boot menu I get errors as shown in this video:!Ao6vb-vAMfBxa3F6dXqLyxwCr3Q
Do note that In the above video, grubx is fedora1 entry and shimx is fedora entry in boot menu.