Is there a way to disable the super key?

Hi everyone. I just installed Fedora 36 on my laptop which is having a problem with the keyboard (the windows key keeps pressing itself even if it’s not phisically stuck, but if i press it a couple of times it gets back working).
Now i don’t really care about this laptop, I only use it to study on pdf nothing more.
So, since i dont want to repair it, is there a way to completely disable the key? So i don’t run in shortcuts and other problems like not being able to click.
I already disable most of the shortcuts through settings (gnome help was showing up every few seconds), but i still get the “click” problems.

You may want try doing some modifications with Gnome Tweaks under additional layout options.

Apart from disabling the shortcuts that involve the Windows (Super) key as suggested… you might want to upgrade that laptop

Fedora 36 has been end of lifed since May 16