Invisible Mouse pointer


Installed fedora 31 on a Dell PowerEdge 710 and on the console, the mouse pointer is invisible. I can see that it is present because buttons are highlighted, but it is invisible.
It is driving me nuts because nothing seems to work.

Do your mean the terminal-emulator, or the kernel-console?

On the login screen on the console and even after logging in. The strange thing about this is that it was fine with Fedora 29, and problem started after upgrading to 30.
I have another server, a Lenovo 550, which is running Fedora 30 without a problem.
I am using openbox and LXDE desktop

Maybe the icon for the mouse pointer is gone, somehow?
Maybe your just try to install KDE, or GNOME, or MATE, or Cinnamon and see if trouble persist? No other guesses for now… Also i’m on 31st, last updated ~20 days ago. Will update tomorrow.

PS: If LXDE isn’t legacy now?


That is not the problem. I tried the LXQT live CD and no mouse.

Reverted to Fedora 29 and mouse works perfectly



Do your willing to try the version 31? Or Gnome desktop… or gdm as a login manager? Default, etc… modern login managers are important part of the whole graphics thingy. I have had troubles in Arch when tried use plasma-shell without the login-manager.

As an aside: Seriously, someones just can lost the their beloved mouse at the point of upgrading the machine!

Good Luck to your!

I think that I will stick to Fedora 29 and LXQT for a while. The mouse works as expected and I need the server to be productive.

Something has changed though. From Fedora 30, the mouse does not work, even in the graphical installer!



I had this exact same problem on a PowerEdge T430 this past week. Fedora 31 server edition was very difficult to install as a result. Stock Matrox (G200eR2 from lspci). The system was also unstable once I did get it installed and hung on me twice. Tried to move to Fedora 31 with Centos 8’s EPEL repo so empty. Finally decided that Centos 7 was the distro for me right now. Quite disappointing.

I think that the problem is with the mga driver. I would like to change the card but the slots on the Poweredge can only handle 15W cards. Any modern graphics card cannot work
Right now, I am remaining on Fedora 29

🛸️ vits95 flood

Fedora is Red Hat’s test bed. Every bug faced by some there may help people with your quality standards. This is rather wonderful than disappointing.

Hmmm… as someone who wants to use F31 (not Rawhide), this is disappointing, not wonderful. If it was just the graphics card, that’s one thing. The system locked up within minutes of booting. IMHO, the shouldn’t happen, and I hope that the kernel isn’t the base for some future install of RHEL or Centos. But again, my opinion.

vits95 flood

:troll_face: This particular Kernel version isn’t. But the Kernel is. They rather will not go up for a HURD, a Redox, or a BSD.
:mega_troll_face: It’s pity.