Installing Viber (rpm) issue

Hello! I downloaded viber.rpm package from viber site. And I tried to install it via “sudo dnf install ./viber.rpm”. And Error appears:

"Problem: conflicting requests

  • nothing provides needed by viber-"

After some googling I downloaded from somewhere on the internet file compat-openssl10-1.0.2o-11.fc33.x86_64.rpm and installed it and then Viber was successfully installed. But I’m not sure about this solution. I can’t trust the site I downloaded this file (compat-openssl10-1.0.2o-11) from and maybe this is not good idea to use such a solution.
Maybe are there some other solutions of this problem? I’m totally new in Linux.

You can easily install it from flathub
.rpm is okey.

Is it was downloaded from dnf or some other sites if other site can you provide some details which site was that because .rpm files mostly stay with with system and it is a system component.

I recommended use flatpak and remove that package and download from dnf itself if you can’t then do it with dnf history undo no.
With dnf history.

I don’t exactly remember from which site I downloaded this file (compat-openssl10-1.0.2o-11.fc33.x86_64.rpm). It was site like this:
I encountered info on the internet that this package was removed from Fedora’s repos. Maybe because it is deprecated.

I installed this file compat-openssl10-1.0.2o-11.fc33.x86_64.rpm on my previous Fedora 35 and now I reinstalled Fedora 35 and now I have a clear OS without this compat-openssl10-1.0.2o-11.fc33.x86_64.rpm installed.
Thanks, now I’ve tried to install Viber from flathub. It seems working. But I wonder if it could be that the flatpack package also includes this deprecated library (compat-openssl10-1.0.2o-11.fc33.x86_64.rpm)? I don’t really know how it works.
I.e. can it be that Viber itself uses deprecated lib (compat-openssl10-1.0.2o-11.fc33.x86_64.rpm)?

Flatpak does not work like that it is not a .rpm it is fundamentally different
I can’t talk about viber you can ask them about your specific issue.

1 Like