Installing steam on asahi linux

the command sudo dnf install steam gives me the following error

Last metadata expiration check: 0:00:50 ago on Fri Aug 25 19:25:40 2023. allow_vendor_change is disabled. This option is currently not supported for downgrade and distro-sync commands No match for argument: steam Error: Unable to find a match: steam

How can I solve this error?

Hello Sergei and welcome to ask :fedora:

Steam would be installed with that command from the rpmfusion-nonfree-steam repo which should be enabled through the gnome software panel. Did you enable the third-party repos with gnome software before attempting to install steam?

You can make a quick check to see what repos are enabled with the command dnf repolist which should show all currently enabled repos.

rpmfusion-nonfree is installed but not rpmfusion-nonfree-steam repo

how to enable this repo?

There is no steam package for aarch64, which is the architecture that Apple Silicon Macs running Asahi run, so you won’t be able to install it even if you enable rpmfusion-nonfree. At the present time, Steam isn’t supported on this platform. There’s ongoing work to make it available (via emulation, unless Valve decides to release an aarch64 build of it) down the road, but nothing in usable form just yet.

1 Like

Did you read my earlier post?

Jeff, see what Davide said. Steam is not available on non-x86_64 including Asahi

How do people then manage to use steam and play windows games on their Mac?

As stated above, the hardware architecture must be compatible.

If the mac uses arm architecture hardware then steam is not available and users cannot use it to play games with steam.

If the mac is an older one that uses intel x86_64 architecture then the fedora OS installed is x86_64 and steam can be easily used.

If you’re asking about on macOS, the Steam client runs under Rosetta 2 emulation

The Windows games would also be emulated (plus translated via the Wine-based Steam Play runtime)

1 Like