Steam through dnf not working?


Newly installed Fedora 35 here, simply updated and installed my nvidia drivers as well as an fsync kernel.

When I try to install steam (sudo dnf install steam) and launch it, it gave me some error about missing, and after looking things up online, I saw there was a missing symlink and fixed that.

Now, it gives me another error “Could not load module ‘’”.

Anyone know why this could be happening?

Steam is not available in Fedora repos because it is proprietary. If you were able to install it with dnf, you would have had to add a third-part repo to do so. Which one was it?


i also upgraded from 34 to a35

Latest packages:

dnf clean all
dnf install steam
it works for me

But you could try the flatpak version!

I use steam on fedora 34 installed the same way with no issues. However, I have not tried it in fedora 35 yet.

I wonder if the missing module is due to some change in the packages steam relies on with the fedora update.

Did you do the steam install after or before you upgraded to f35?
Have you tried to do a “sudo dnf reinstall steam”?

I found the module you said was missing at


I also have no ‘’ installed anywhere. I find several different ‘’ files in different locations


along with various supporting files.

All these files were either installed when I used dnf to install steam (or other packages) or when I first started steam and did the config. The ones in ~/.local/* I am certain came from steam. The ones in /lib and /lib64 apparently come from the bzip2-libs package.

I still can’t get Steam to work.

Tried installing from the APP Store (enabling RPM Fusion Non Free). It seemed fine, but I cant open the app.

Then I removed it and did it all again using DNF (which is the same thing, I am guessing), but I get the same error.

$ steam[13397]: Running Steam on fedora 35 64-bit[13397]: STEAM_RUNTIME is enabled automatically[13471]: Steam runtime environment up-to-date![13397]: Steam client's requirements are satisfied

And then nothing happens.

The only thing I did to this Fedora 35 install was to try to run steam. I think it worked once or twice (but that’s it).


Please post the output of sudo dnf repolist and sudo dnf list installed steam

You also should not be running it from the command line, but from the icon which it automatically installs in the activities menu. There are options which it uses there that you did not add on the command line.

Repo list

repo id                         repo name
fedora                          Fedora 35 - x86_64
fedora-cisco-openh264           Fedora 35 openh264 (From Cisco) - x86_64
fedora-modular                  Fedora Modular 35 - x86_64
rpmfusion-free                  RPM Fusion for Fedora 35 - Free
rpmfusion-free-updates          RPM Fusion for Fedora 35 - Free - Updates
rpmfusion-nonfree               RPM Fusion for Fedora 35 - Nonfree
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 35 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-updates       RPM Fusion for Fedora 35 - Nonfree - Updates
updates                         Fedora 35 - x86_64 - Updates
updates-modular                 Fedora Modular 35 - x86_64 - Updates

list installed

Installed Packages
steam.i686                   @rpmfusion-nonfree-updates

PS. I tried running from the terminal to get some kind of messages. When I run directly from the icon, steam loads (with that “terminal like” loader to download updates) and quickly disappears.

Thanks a lot for dedicating time to help :slight_smile:

For me it runs the download, then runs the installer to install the updates, then launches the actual steam window.

How did you install steam? Was it using dnf install steam or dnf install steam --user?

If you did the former that could explain the failure since the normal user cannot do the updates properly and steam does not run as root.

Maybe you should uninstall steam ( dnf remove steam ) then reinstall it in user mode ( dnf install steam --user ). Once that is done then once again try launching it.

I also do not see this repo in your list.

rpmfusion-nonfree-steam                                  RPM Fusion for Fedora 35 - Nonfree - Steam

To enable it on fedora 35 open the gnome software app and at the upper right the ‘hamburger’ menu icon allows opening the software repos tool then under third party repos you will find the rpmfusion-nonfree-steam repo.
That repo is what I used to install steam

I may have deleted the repo afterwards, not sure what happened.

Can’t run it with --user.
dnf install: error: unrecognized arguments: --user

Is there any other arguments to do so? Do I have to enable anything?

Actually, the process keeps running after the window disapperas:

I just can’t see anything related to it.

In a Terminal Can you:

  1. Move the Steam Folder
    mv ~/.local/share/Steam ~/.local/share/Steam.old
  2. Run steam
    steam steam://open/games

It may prompt you that it can’t find the Steam folder, do reinstall.

It should re-download and then get you back to the login or hopefully provide some additional information of what’s going wrong.


This ran Steam for once. Then, after closing it, the same error happened again.

Since it was a fresh install of Fedora, I reinstalled it. It seems to be working fine now…

Thanks for your time!

1 Like