Installing Fedora 30 from USB flash drive results in Notify NFS peers of a restart, then system shutdown

Installing Fedora 30 from a USB flash drive, after some messages about bluetooth, which I attempted to disable, I get this message: Notify NFS peers of a restart
The system then shuts down without loading Fedora.
The Fedora 30 USB flash drive was created using Fedora Media Writer (3rd try).
The following kernel parameters were used:
nomodeset nouveau.modeset=0 rdblacklist=btusb

You know tomorrow fedora 30 will be closed because 32 will be launched tomorrow?

1 Like

No, Fedora 30 goes end-of-life a month after Fedora 32 is released.


I’m inclined to start with Fedora 30 because it works with an audio streaming software I’m using. Thanks.

Give Fedora-32 a shot @tersewings. You have nothing to loose

1 Like

This is what I’m getting with Fedora-31 and the following kernel params:
nomodeset nouveau.modeset=0 rdblacklist=uvcvideo,iwlwifi,btusb

I’m not even sure what it’s failing on now. Is it tpacpi_bluetooth_sw?

This is a dual boot with Windows 10 on a brand new machine:
Lenovo Laptop ThinkPad X1 Extreme 20MF000MUS Intel Core i7 8th Gen 8850H (2.60 GHz) 16 GB Memory 512 GB SSD NVIDIA

What happens when you use DVD to boot? The screenshot doesn’t say much. Can you extract a boot log? You don’t want to use Fedora-32?

Since this is a brand new machine that came with Windows 10 and no previous linux installation, I don’t know how to extract a boot log. Any suggestions on how to do so would be helpful. I would try Fedora-29 before 32 because it’s more likely to work with the audio streaming software I’d like to use this machine for.

I recommend not to install any unsupported release since this poses a security risk. The oldest release you should install (at this moment) is Fedora 31.

What’s the audio streaming software you are referring to?


After trying different versions of Fedora and booting from DVD with no success, I tried installing Manjaro, which also failed, but with a more specific error message that the machine reached a critical temperature of 126 C–obviously not true. I googled the error and found this post:

Updating the Lenovo X1 bios finally solved the problem. None of the kernel params modifications I had tried earlier were necessary. Up and running on Fedora 31 now.

Btw, there are plans to ship Lenovo preloaded with Fedora soon. Not sure if it’ll be dual boot with Windows though.

Thanks for your help.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.