Icebreaker on Fedora 35 (and, sadly, up)

Does Icebreaker work for anyone on Fedora 35? I haven’t gone back and test Fedora 34 (assuming it is available there). On Wayland and X11, icebreaker just crashes for me. I’ve tried with intel graphics and amd graphics.

1 Like

Hmmm. I can recreate by deleting my ~/.cache/mesa_shader_cache/ directory. After that, it just crashes on startup. This must be something with the SDL12 compat thing. @ngompa, any idea what’s going on here?

I tried deleting my cache and rerunning Anagramarama. It still runs fine so it is not affecting all SDL12 games. (I then ported Anagramarama to SDL2. I may port Icebreaker so I can give it a try.)

1 Like

I got around to trying it again on Fedora 36. It is working now.

It still crashes for me. The problem is hard to easily track down. :frowning:

It’s back to crashing for me on Fedora 38.

I could use a break… I’ll poke at it a bit and see if I can find out what’s up.

I need someone smarter than me to help figure this out. :classic_smiley:

Here’s the backtrace…

Thread 3 "icebrea:disk$0" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe7fff6c0 (LWP 334025)]
0x0000000000418800 in flock ()
(gdb) bt
#0  0x0000000000418800 in flock ()
#1  0x00007ffff48bbbfc in disk_cache_write_item_to_disk
    (dc_job=dc_job@entry=0x7fffd403e6b0, filename=filename@entry=0x7fffe0000b70 "/home/mattdm/.cache/mesa_shader_cache/0a/3f0df508dae8286fb2ffd4379e8b34176ddb05")
    at ../src/util/disk_cache_os.c:765
#2  0x00007ffff48ba185 in cache_put (job=job@entry=0x7fffd403e6b0, gdata=gdata@entry=0x0, thread_index=thread_index@entry=0) at ../src/util/disk_cache.c:460
#3  0x00007ffff48c3e41 in util_queue_thread_func (input=input@entry=0x5c7350) at ../src/util/u_queue.c:309
#4  0x00007ffff4912ecc in impl_thrd_routine (p=<optimized out>) at ../src/c11/impl/threads_posix.c:67
#5  0x00007ffff7dd3907 in start_thread (arg=<optimized out>) at pthread_create.c:444
#6  0x00007ffff7e59870 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81

I got the same backtrace but didn’t have the time to look at it further.