I cannot get user's .pam_environment to work


I have been instructed to set an environment variable using the user’s ~/.pam_environment file. This was recommended as preferable to using .profile or .bash_profile. I have tried several ways of specifying the content, but none of the ways work.

One way is MOZ_ENABLE_WAYLAND OVERRIDE=1. Another way is MOZ_ENABLE_WAYLAND=1. These are the two ways that make the most sense, to me, so I won’t mention other things I’ve tried. I completely log my user out and log back in to GNOME. But, the setting is still empty.

I read a 2016 post somewhere that said that this feature is/was considered a security risk, so it was disabled. Yet, a fairly recent Firefox bug report recommends using it.

So, does anyone know whether ~/.pam_environment works in Fedora 30? If the answer is Yes, can anyone tell me what I’m doing wrong?

I tested doing the exact same thing on Arch Linux, and it worked perfectly. So, I can only assume that ~./pam_environment is disabled in Fedora.

If Fedora is going to disable documented functionality, I think they should revise the documentation to inform the users.

Ok, going back to the “old way” (putting it in ~./bash_profile) works. So, that’s what I’ll do for now.

I found an old article and thread of replies on lwn that discusses this issue. After reading it, I see that there are vast differences in the ways environment settings are handled between X and Wayland. That is probably what is messing me up.

1 Like