HOWTO: Installing Canon MX920 wireless printer

Despite being a regular user of Silverblue for a while, I had not been able to get my wireless Canon MX920 printer installed and working on my Silverblue laptop (tried with F33 and F34, I believe) using the Printers menu from Gnome Settings. Past attempts to add the printer in this manner just seemed to silently fail, with only a trace of the error in the journal.

Oct 17 15:13:52 infidelicious cupsd[1662]: REQUEST localhost - - "POST /admin/ HTTP/1.1" 200 163 CUPS-Set-Default client-error-not-found
Oct 17 15:13:52 infidelicious gnome-control-c[112793]: cups-pk-helper: setting default printer to Canon_MX920_series failed: client-error-not-found
Oct 17 15:14:09 infidelicious gnome-control-c[112793]: g_hash_table_ref: assertion 'hash_table != NULL' failed
Oct 17 15:14:11 infidelicious cupsd[1662]: REQUEST localhost - - "POST /printers/Canon_MX920_series HTTP/1.1" 200 423 Print-Job client-error-not-found

However, I discovered that it was possible to get it working on F34SB by using the CUPS web interface. So I’m sharing these steps for anyone (including future me) that might have similar problems.

  1. Browse to http://localhost:631/
  2. Select the Administration link at the top of the page
  3. Click the Add Printer button. (If asked to login, provide your username/password)
  4. Choose the Canon MX920 series (Canon MX920 series) radio button from the list of Discovered Network Printers
    image
  5. On the next screen, leave everything as is and click Continue. (You might be able to tick the Sharing box, but I have not tried that feature)
  6. Choose the Canon MX920 series - CUPS+Gutenprint v5.3.4 model from the list. Click Add Printer
    image
  7. Adjust printer options as you like; I left these alone. Click Set Default Options.

Now you should be able to print successfully from any app and the printer should show up in Gnome Settings.

I’ve not confirmed if the printer works with any Flatpaks I have installed, but my main use case (printing from Firefox installed on host) is satisfied.

Hope this helps someone!

(edit: noted this was a wireless printer and it was performed using F34)

6 Likes

Sweet, thanks for taking the time to write this up!

Hello @miabbott and @jlebon ,
This is strange for me. With F34 Silverblue, I connected my Brother printer directly via USB to the PC and it automatically was installed as such. After reading this post, and since I had to install F35 due to HDD failure and was starting fresh, I hadn’t connected my printer yet, till this am. I decided to use the Lan switch to connect it in order to use it more freely with different devices. When I followed the “Add Printer” assist in “Settings” of Gnome, it came up with a generic text printer with no real functionality, and more specifically it no longer recognized it as a Brother printer. I searched for the appropriate driver in the database and selected it, but haven’t yet tested it. I noticed it is now the CUPS driver and not the Brother specific PS3 driver. [Edit - 10:28EDT] So, on either USB or via networking over lan, the printer prints garbage using the CUPS drivers for some reason. This wasn’t a problem with F34 for sure.
[Edit - 20211021-0840] So today on booting, the foomatic printer drivers were “found” to be needed for my printer (which was no longer connected). I’m going to try to print to it later, will update.
[Edit:20211022-11:04EDT] No luck printing, link to device address is automatically set to browse localhost:631. Guess I’m back to messing with CUPS (again after YEARS of no printing difficulty).