How to use Intel Iris Xe Max laptop discrete GPU on Fedora

It use the same kernel modules as the intel Iris Xe integrated GPU, so I can’t block the i915 driver.

The kernel module is loaded.

What is the problem you want help with?
You seem to have proved you have the hardware and its driver is loaded.
P.s. please cut-n-paste text rather the screen shots.
Use the preformatted text feature like this:

type or paste code here

Sorry,it is my mistake.

The discrete GPU driver is not loaded, so I can only use the Iris Xe integrated graphics.
I don’t know how to load double i915 graphics driver at same time.

Do you have two GPUs on your machine?

If yes and both are Intel then you only need to load the driver once and it will handle both GPUs.

Why do you think its not doing that?

glxinfo | grep render           
direct rendering: Yes
    GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer, GLX_MESA_swap_control, 
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)

The render device is the Iris Xe integrated GPU now ,not the Iris Xe Max discrete GPU.

I have edit the /etc/modprobe.d/i915.conf add the line and dracut -f

options i915 force_probe=4905

It not work.

The Intel discrete GPU PCI IDs

The Intel double GPUs laptop is same as NVIDIA Optimus, not the dedicated GPU direct connection.

So I think I can’t disable the integrated graphics.