How to uninstall application

I am using Fedora 37, Gnome desktop. I have an application (Hydrapaper) that is apparently installed and opens its window, but it doesn’t function properly anymore. I want to uninstall it and reinstall it from a different source.

Unfortunately, the Software app doesn’t list it as installed. I tried to use dnf and flatpak uninstall commands but neither sees the application which is listed in my application/accessories menu. If I can’t uninstall this with Software I need to do so manually but I can’t find the executable.

1 Like

Things listed in your menus correlate to *.desktop files on the filesystem somewhere. Inspecting the contents of those files will indicate where the application’s main binaries are. You can then use rpm -qf <full-path-to-executable> to find out if the application is part of a rpm package. If it is part of a flatpak or some other container tech, that should be obvious from the file path.

You can try the following command to look for the *.desktop file.

grep -r -l -i hydrapaper -- {/usr,~/.local,/usr/local}/share/applications/*

You can use grep to list the exec lines in the desktop file as well. e.g.

$ grep -i '^exec' ~/.local/share/applications/ApacheDirectoryStudio.desktop

And just to demo the rpm command …

$ rpm -qf /opt/ApacheDirectoryStudio
file /opt/ApacheDirectoryStudio is not owned by any package

So the above is not part of a rpm package and could be removed with rm -rf /opt/ApacheDirectoryStudio. (And likewise, its desktop file could be manually removed).

If, however, the program is part of a rpm package (or a container like snap or flatpak), then it should be removed using the package manager. e.g.

$ rpm -qf /opt/google/chrome
$ dnf remove google-chrome-stable
Dependencies resolved.
 Package                     Architecture  Version                 Repository             Size
 google-chrome-stable        x86_64        108.0.5359.124-1        @google-chrome        300 M
Removing unused dependencies:
 liberation-fonts            noarch        1:2.1.5-2.fc36          @fedora                 0  

Transaction Summary
Remove  2 Packages

Freed space: 300 M
Is this ok [y/N]: 

Thanks for that suggestion. That first grep command its not yielding any output.

I did manage to uninstall a flatpak using the name ID. It confirmed that the uninstall was complete. However, the application is still listed in the menu and its window still opens. Maybe I had two instances?

The second grep command output (using Hydrapaper.desktop) says no file or directory.

The opt directory doesn’t have any related files.

1 Like

I’m not very good with flatpaks. I try to avoid them and use the rpms whenever possible. So it is no longer showing up in the output of flatpak list?

Correct, no longer listed.

One possibility is that the application is still loaded in the “caches”. There are ways to forcibly clear those, but the easiest way to be sure that that isn’t the problem is just to reboot the PC. Have you rebooted your PC since you uninstalled the application? (Yes, an app can still hold references to deleted files and continue to operate (sort of) after it has been uninstalled.)

I just rebooted but no change - app is still listed and executable. I tried the dnf remove command still doesn’t find a match.

Sorry, flatpaks are a bit of a mystery to me. I guess about all I could suggest is to study the man page (man flatpak) and see if you can figure out what is going on. Sorry. :confused:

Could you please share the outputs of:

flatpak list


rpm -qa | grep -i hydra

dnf needs exact package names, so if you ran dnf remove hydrapaper but the name of the package is something else, it won’t find it. So we need to check what the exact name of the package is, if it was installed using an rpm.

We can also try locating the binary that’s running. You can run it from your applications menu again, and then check the system monitor for running processes to see if its listed. The “properties” option when one right clicks on a process in the gnome system monitor shows the command line. One can also use the terminal:

ps aux | grep -i hydra

will show us if anything called hydra.. is running, assuming the binary is called hydra...

PS: given that the grep commands for hydrapaper didn’t produce results, it’s most likely that the binary is called something else.

1 Like

flatpak list:

Gradience                                com.github.GradienceTeam.Gradience                    0.3.3        stable        flathub   system
Extension Manager                        com.mattjakeman.ExtensionManager                      0.4.0        stable        flathub   system
Fedora Platform                          org.fedoraproject.Platform                            36           f36           fedora    system
Fedora Platform                          org.fedoraproject.Platform                            37           f37           fedora    system
Freedesktop Platform                     org.freedesktop.Platform                       21.08         flathub   system
Mesa                                     org.freedesktop.Platform.GL.default                   21.3.9       21.08         flathub   system
Mesa                                     org.freedesktop.Platform.GL.default                   22.2.4       22.08         flathub   system
Mesa (Extra)                             org.freedesktop.Platform.GL.default                   22.2.4       22.08-extra   flathub   system
nvidia-510-68-02                         org.freedesktop.Platform.GL.nvidia-510-68-02                       1.4           flathub   system
nvidia-515-57                            org.freedesktop.Platform.GL.nvidia-515-57                          1.4           flathub   system
nvidia-515-65-01                         org.freedesktop.Platform.GL.nvidia-515-65-01                       1.4           flathub   system
nvidia-515-76                            org.freedesktop.Platform.GL.nvidia-515-76                          1.4           flathub   system
nvidia-520-56-06                         org.freedesktop.Platform.GL.nvidia-520-56-06                       1.4           flathub   system
nvidia-525-60-11                         org.freedesktop.Platform.GL.nvidia-525-60-11                       1.4           flathub   system
openh264                                 org.freedesktop.Platform.openh264                     2.1.0        2.0           flathub   system
openh264                                 org.freedesktop.Platform.openh264                     2.1.0        2.2.0         flathub   system
GNOME Application Platform version 42    org.gnome.Platform                                                 42            flathub   system
GNOME Application Platform version 43    org.gnome.Platform                                                 43            flathub   system
Adwaita dark GTK theme                   org.gtk.Gtk3theme.Adwaita-dark                                     3.22          flathub   system
Adwaita theme                            org.kde.KStyle.Adwaita                                             5.15-21.08    flathub   system
Adwaita theme                            org.kde.KStyle.Adwaita                                             5.15-22.08    flathub   system
KDE Application Platform                 org.kde.Platform                                                   5.15-21.08    flathub   system
KDE Application Platform                 org.kde.Platform                                                   5.15-22.08    flathub   system
QGnomePlatform                           org.kde.PlatformTheme.QGnomePlatform                               5.15-21.08    flathub   system
QGnomePlatform                           org.kde.PlatformTheme.QGnomePlatform                               5.15-22.08    flathub   system
QtSNI                                    org.kde.PlatformTheme.QtSNI                                        5.15-21.08    flathub   system
QGnomePlatform-decoration                org.kde.WaylandDecoration.QGnomePlatform-decoration                5.15-21.08    flathub   system
QGnomePlatform-decoration                org.kde.WaylandDecoration.QGnomePlatform-decoration                5.15-22.08    flathub   system
OpenRGB                                  org.openrgb.OpenRGB                                   0.8          stable        flathub   system

rpm -qa | grep -i hydra (or any form of the name) doesn’t produce an output.


ps aux | grep -i hydra outputs:

scott       3370  0.0  0.3 635112 61720 ?        Sl   Jan05   0:00 /usr/bin/python3 /usr/local/libexec/hydrapaperd
scott     126620  7.7  0.7 1610964 121748 ?      Sl   09:29   0:00 /usr/bin/python3 /usr/local/bin/hydrapaper
scott     126669  0.0  0.0 222152  2172 pts/0    S+   09:29   0:00 grep --color=auto -i hydra

1 Like

That output of your ps command seems to indicate it was locally installed.
Clearly there is a hydrapaperd daemon and the app hydrapaper running.
Did you install it from github or some other source that you remember?

Can you find the related .desktop file in /usr/share/applications/ or /usr/local/share/applications or ~/.local/share/applications/ to see which is actually showing up on the menu?

Maybe the source is located under your Downloads directory.

I installed an app as an appimage and the first time I ran it from the cli the app created a .desktop file in ~/.local/share/applications/. Unexpected, but welcome as it made launching the app easier without using the cli. The result though was that to remove the app totally I had to remove the .desktop file manually as well as removing the appimage.

1 Like

At this point I can’t recall how Hydrapaper was ultimately installed. I do recall having issues with the app store versions, at the time.

I am unable to locate the desktop file. It isn’t in the folders you mentioned above. I may have to reach out to the developer.

you could try looking for the desktop file:
sudo find / -name *.desktop 2> /dev/null | grep -i hydra

you could also try using plocate (if it’s installed) to find the file
locate -i hydrapaper

1 Like

Ah, yes, I forgot about /usr/local. I should have included that in the previous example search command I provided. But as Jeff commented, things under /usr/local are never part of a package manager. They need to be managed by some other means. Often there is a uninstall script in the same repo/source-tree that was used to install things there.

Edit: I updated my earlier post to include /usr/local in case someone else comes across that in the future.


Searching the whole drive would work as a last resort, but it is probably overkill. I think the following command would be quicker and is likely to yield results.

grep -r -l -i hydrapaper -- /usr/local/share/applications/*

It looks like it was manually installed into /usr/local. Removing it requires removing all files manually—that’s sort of why we use rpms and package managers.

So there are two things to do:

  • remove the desktop file entry to remove the application from your application list but leave the application “installed”
  • remove all the files that were installed: this requires a little more investigation to figure out what files were installed in the first place—not necessarily straighforward.

I also forgot about /usr/local/share/applications/ as containing .desktop files, even though I have a few there. Thanks for the reminder Gregory. :+1:

I also updated my earlier post to include that as a possible location for the .desktop file.

1 Like

Thanks Joe - that works perfectly.
Here are the files I found:



I also found the executable application in /usr/local/bin , as noted above. I will attempt to remove these traces first and reinstall via the software manager.

I reinstalled the rpm and during launch I get this :

(org.gabmus.hydrapaper:31874): Gtk-CRITICAL **: 13:11:38.625: gtk_widget_set_parent: assertion '_gtk_widget_get_parent (widget) == NULL' failed

The rpm installed app is not working as expected. I should probably contact the dev on this?

Thanks to all here who contributed to this thread - very helpful.

1 Like

It looks like someone already reported that problem upstream.

And someone also said they found a workaround.


Hi, i was actually able to solve this problem. What I realized is that even with the flatpak version of hydrapaper didn’t work because I had dark mode on. What I had done is installing a software called “dconf editor” which would let me dig deep into all the settings of the gnome shell. To change the wallpaper in dark mode you need to go into
and change the path for the file for picture-uri-dark. I believe the hydrapaper generated wall paper is in
“user” being your username.
However, i still haven’t been able to locate the exact location of configuration file/code for the shell through terminal.