How to permanently disable baloo_file_extractor?

Fedora 34, KDE Spin

I programmatically create a large number of text files. The indexing system immediately tries to index them. As a result, huge memory consumption and 1 processor core constantly working.
At the same time, I absolutely do not need any indexing of the contents of the files.
I tried disabling this service:

[ivan@fedora ~]$ sudo balooctl disable
[sudo] password for ivan: 
Disabling and stopping the File Indexer
[ivan@fedora ~]$ balooctl status
Baloo File Indexer is running
Indexer state: Indexing file content
Indexing: /home/ivan/Documents/MoscowBase/DOC COMMON BOOKS/Социология права - Шереги/Социология права - Шереги.doc
Total files indexed: 5,093
Files waiting for content indexing: 47
Files failed to index: 0
Current size of index is 5.87 GiB

but as you can see, he refused to complete his work. Deleting a process in the System Monitor doesn’t help either: the process is immediately re-created.

How can I turn off a service I don’t need?

If that is run in userspace you should execute it without sudo.

I think you can also do
System Settings -> Search -> File Search -> Disable

If you’d like to have it still running you can configure it to ignore folders and such. Baloo/Configuration - KDE Community Wiki


if baloo is run as a service (and it probably is) then you can use
“sudo systemctl disable baloo”
to disable it. I am guessing on the name of the service since I don’t use baloo, but you may be able to find it with
“sudo systemctl list-units”
and parse that for the actual service name.

Since you have balooctl you might be able to control it more directly with its own commands that often can be found with something like “balooctl --help”

Usually disabling does not also stop at the same time. Disabling infers that it will not automatically restart. Stopping involves stopping the currently running instance. Maybe “balooctl stop” would work.

1 Like

Keep in mind that some KDE applications also use baloo so if you inhibit it, those applications will have reduced functionality.

My recommendation is to change the configuration of baloo to one or both of these things:

  • Exclude the directories from baloo where you create lots of files
  • Change baloo so that it only indexes file names instead of file content

sudo systemctl list-units | grep baloo

is better because you don’t have to hunt for it.

Thank you!