How to know if a given patch is implemented in my kernel (stock Fedora)?

Hi everyone,

I’m using Fedora on my laptop with only one caveat… I have sound only when using a headphone or when I connect a monitor that have speakers. The stock speakers is not working.

This issue has nothing to do with Fedora (nor any other distro)… It’s just the vendor (Asus) that is not fixing it…

However recently I found someone able to fix it with some commands (described here
But in my case it didn’t work…

However, I found a longer explanation of the problem described here:
In here, they are stating that in order for those commands (from the link above) to work the kernel should have 2 patches (shown in the first section of the page).

I’m going to admit that I didn’t get at all how to make use of those patches, particularly when they are just a bunch of source code).

My first question is, how I can know if my kernel have them? I’m running stock Fedora 6.5.12-300.fc39.x86_64 (I ran last update a moment ago).

I guess that these patches did not get into this kernel since the fix is not working.

So my second question is, how can I patch the kernel with the 2 mentioned patches?

While I’m used to run Linux and also use the command line, I’ll have zero experience with kernel stuff though so I’ll probably need very accessible guides :slight_smile:


The first patch made it upstream for 6.6, but seemingly not the second one. The last mail in that thread says:

I don’t expect this patch to be merged. Fortunately, the new 331 BIOS that came out
today for ASUS ROG ALLY fixes all my known issues that I had with the 330 BIOS
on Nobara, and is actually usable for me. Thanks.

You might want to see if there’s a BIOS update available for your device.

You’re a couple of updates behind. 6.6.3 is now stable.


Thanks for the reply!
How can I update the kernel?
I mean, I’m just running sudo dnf upgrade --refresh which from time to time seems to upgrade the kernel as well…
So I always assumed I was using the latest one (at least the latest one available for Fedora)…

Edit: My laptop has its latest BIOS but it’s already a year old (issued january 2023)… So I guess I’m still screwed with the sound… This is weird that a patch is not merged because one has its own problem solved (or maybe I didn’t get the exact reason)…

Also I’ve already updated to F39…

Edit 2: Nevermind… It seems it was a long time I did not reboot the computer… After rebooting I’m now indeed running 6.6.3-200.fc39.x86_64

I’m going to try again to apply the fix to see if it’ll work, but I guess missing the second patch will not solve it…

Will update here…

Have you rebooted recently?

AFAICT, It hasn’t been merged because (from that thread):

We are currently working internally on adding support for the 2023 ROG
laptops, so we
ask for you guys to hold off on trying to upstream support for these

Stefan Binding

They appear to be employed by the hardware vendor (Cirrus).

Is your laptop a ‘2023 ROG’ ?

Just edited the post above at the same time :slight_smile:

indeed (and my bad) I just rebooted the computer…

It makes sense I guess for the patches to not being merged then…

My computer is an Asus ZenBook UX582ZM (with 12th gen intel).

Just tried to run the fix… Doesn’t fix it :frowning:

When googling I found this page:
In here there are referencing some ASUS models, but mine is not listed…
Also found this 216194 – cs35l41: Platform not supported -EINVAL where it seems to be set as “RESOLVED DOCUMENTED” but in my case I’m still having the error in dmesg:

[    7.664591] Serial bus multi instantiate pseudo device driver CSC3551:00: Instantiated 2 SPI devices.
[    7.770338] cs35l41-hda spi0-CSC3551:00-cs35l41-hda.0: Failed property cirrus,dev-index: -22
[    7.770343] cs35l41-hda spi0-CSC3551:00-cs35l41-hda.0: error -EINVAL: Platform not supported
[    7.770346] cs35l41-hda: probe of spi0-CSC3551:00-cs35l41-hda.0 failed with error -22
[    7.774136] cs35l41-hda spi0-CSC3551:00-cs35l41-hda.1: Failed property cirrus,dev-index: -22
[    7.774142] cs35l41-hda spi0-CSC3551:00-cs35l41-hda.1: error -EINVAL: Platform not supported
[    7.774145] cs35l41-hda: probe of spi0-CSC3551:00-cs35l41-hda.1 failed with error -22

I guess I’m going to stick with not having sound on the speakers (or booting in windows when I don’t have my earphones and that I need to zoom :sweat_smile:)

I read about a similar bug on the Ubuntu forum, also with an Asus Oled…
In the case when the girl was on Windows and restarted the machine to enter Ubuntu, this bug occurred.
She discovered that if she booted her machine straight into Ubuntu, this bug didn’t happen and everything worked normally.
Does this happen to you too?

Sound issues in linux are not unusual, so it is worthwhile having a USB sound dongle to use while waiting for fixes. Look for a vendor that identifies the chipset (some vendors sell assorted chipsets under one model name) and check on the