Sound not working with kernel 5.5

So, i think it is coming up on a year that i have been using fedora, and it works great. I initially chose it because it was the only one that got hibernation done out of the box, and i just want to say thanks for freeing me of the closed system with a fruit symbol.

I am running on a Acer Swift 5, 15’’ , from last year, ie with i5-8265. One of the lightest 15’’, just over a kilo, but maybe quite rare.
So i have been without audio in from the start, and that never changed. My forays into the jungle of audio problems have been met with a thicket of detail, that i had not enough reason to penetrate.

But with the latest update, the first 5.5 kernel, audio out has stopped working. For me i am happy to boot into the 5.4 kernel and wait. But if anyone wants to pursue this, i would spend the time to do as someone guides me to (read: i will not be reading tons of cryptic docs)
But i can run scripts, post the output, that sort of thing.

Torsten

same to me,
I run on a Lenovo X1 Carbon 7th. The update to Fedora 31 pushes me into some trouble. Unpredictable freezing (X11) and with Kernal 5.5 I lost my soundcard. External devices are working well, so I think its a matter of the driver. But I can not do another update, because this will delete my 5.4 kernel.

If somebody can help us out, I would appreciate this :slight_smile:

cheers Alex

To change the setting, simply open up /etc/yum.conf or /etc/dnf/dnf.conf in your favorite text editor. Look for this line:

installonly_limit=3

did the trick. but di not fix the sound issue of course.

@alex89 I found that an external Bluetooth speaker still works. Not sure if that helps you, but it did help me.

believe it or not. but running
dnf install alsa-firmware + reboot
fixed the issue on my machine. and my digital mic is also working now.

I was hopeful, alas…

But the 5.5.7 kernel just came, and that did it. Sound is coming out of the speakers again :slight_smile: