How to install mono with MSbuild for unity project?

I have installed the dotnet sdk(version 7) and mono-devel from the fedora repository, but even this I get a message saying that for vscode to work with my unity project it needs mono with MSbuild. How do I resolve this issue? I have also installed unity successfully, if that helps.

Have you tried to use VSCode?

I have and it worked for a little bit( I made a reddit post). I assume that an update to the C# extension is what caused everything to not work as now it is saying that I need the dotnet framework which is only available for windows. I currently reinstalled fedora, I’ll provide a screenshot of what visual studio code is spitting out.

after switching to version 1.26.0 of the c# extension, i get the same error:
This has been frustrating and I am giving up on this issue after spending multiple days on this.

You may need to install mono-complete instead of just mono from the fedora repo.

I did that, however I still get the same issue. I’ll see if recompiling mono helps.

I have found a solution on how to setup unity and vscode. it doesn’t require mono, all it requires is following the instructions on the vscode website and installing the dotnet sdk. Intellisense works for me and I get no errors.