How to install in an older version?

I have a board called eaidk and it is said that chip is rk3228h,the os seems to be fedora 28,it can’t boot from sd card with live cd image,what else can be done?

This is an ARM board? Did you download the ARM image?

This is the img,Fedora-Workstation-Live-aarch64-38-1.6


this is the board.

Did you download the ISO or the RAW image. The ISO has been a problem for me in booting always. The RAW image can be put on to the sd card using the fedora ‘arm-image-installer’ and has always worked for me to boot.

I think the iso is intended for use with a usb device.

I will try this,but I tried to put it in card reader,it should be same as USB disk.
I took a look at arm-image-installer,it seems too dangerous to do so,the board is not on list anyway,I hope there is a way using sd card to boot and go to the os in sd card,without touching the os in the board.
There is a txt from flashing tool,since it can’t be recognized by my pc,I can’t use that way either,but hope it helps somehow

MAGIC: 0x5041524B
ATAG: 0x00200800
PWR_HLD: 0,0,A,0,1

If the SBC is booting from an sd card, then replacing that sd card with another does not affect whatever may be on the first. They are interchangeable that way, just like physically replacing an HDD does the same. AFAIK the SBC boards do not have built in storage for the OS. That is all on the sd card or a usb drive.

Yes, using fedora arm-image-installer to overwrite the original card would wipe it out.
I suggested using another card and since the cards are mostly ~$10 here in the US (unless you get a really large one) that is a quick way to test other distros. (Even the best 128GB sd card is <$25 on

That board seems to have a cortex-a53 chip so it should be 64 bit, but the rest of the board needs the proper drivers as well.

It does have 8gb storage,at first I thought I bought a thing like rpi but it seems much worse,no much useful info online and with an old system that the dnf somehow is broken here,not many softwares,that is why I want a new os instead.

You need to be careful in terminology.
To me saying It does have 8gb storage implies that you are using an 8GB sd card which is used similar to a disk drive in larger machines. It may be that you intended to say 8GB RAM which is not storage.

I don’t know which release version you may be able to boot or use, but AFAIK those SBC boards do not have onboard ‘storage’ other than the firmware. Storage for most is in the form of the sd card or a usb device and RAM is volatile.

Since the OS resides on the sd card it is very simple to try multiple different releases or even different OSes by simply swapping the sd card.

No,not every sbc is the same,it does have 8gb no matter what it is,without any sd card and u disk,it boots itself.

This means you would need to be able to either boot from the sd card exclusively, or to make an copy and be able to restore the onboard storage before you could try newer releases.

  1. can it boot from the sd card if you were to install the raw.xz image onto the card with arm-image-installer.?
  2. how did you put the live image onto the sd card? What command was used and what exact image was used (full file name please).?
  3. How was the original OS installed to the onboard storage?

If the current OS is fedora 28 as indicated one ‘should’ be able to upgrade using the dnf system-upgrade procedure by doing so one release at a time. i.e. F28 to F29, then F29 to F30, etc.

1 I am using windows PC,so I use fedora media writer to write the image file to sd card,can’t try linux tool can’t boot with any image I tried,also Armbian_22.11.1_Rk322x-box_jammy_current_5.15.80_xfce_desktop.img and LibreELEC-RK322X.arm-11.0-nightly-20230322-c4a7662-rk322x.img
2 same as above,file is Fedora-Workstation-Live-aarch64-38-1.6
3 It was installed when I got it.

The dnf command can’t update at all,I will need more specific instructionfor that.

Please post the output of cat /etc/system-release

Take a picture of the single-board computer and post it here, might be we can find out more about it seeing the labels and model numbers.

Fedora release 28(Twenty Eight)

I think it is same as the pictures in link.

What happens if you were to run
dnf upgrade --refresh
followed by
dnf install dnf-system-upgrade-plugin

The second should install the system upgrade plugin or tell you it is already installed.

Once that plugin is installed then you might be able to do a version upgrade, one step at a time with the instructions here.

The part about upgrading from the command line is applicable and includes the steps I noted above. The only difference in upgrades with each release is changing the releasever number in the download step.

I would recommend that you do this, and only upgrade one release version at a time.
Without having an identical machine to test on I can only suggest that you do so carefully, and that you do a full backup of the system before doing each upgrade so you have a copy of what works in case of problems.

Error: Failed to synchronize cache for repo ‘updates’

with or without --refresh,this is why I said it is broken.

How to change default dnf server country

Now update is working,the most useful part is

and modify the repository file in /etc/yum.repos.d

Updating is slow,if it can be done this way,but it is LXDE version seems to be discontinued,should I go all the way up to latest?

There is still error,not found deltainfo and not found updateinfo.
Also no match for arguement dnf-system-upgrade-plugin.

It seems update can go to the last part,but there is only 7GB for whole space,at least 800 or 900MB more is needed,it is not a hard disk in a PC,I have no way to get more space.

Also it is like rock pi,they are using same tool for flashing,but different version.There must be some security during booting since it has so many imgs for booting.