Install Fedora in a Cubieboard 2

I have a Cubieboard mounting an old Fedora 23 and I want to change to a newer version. I found that also version 35 is available for arm: Architectures/ARM/Fedora Linux 35 - Fedora Project Wiki . Cubietruck is in the list, and mounts the same cpu: Allwinner A20.

From I downloaded Fedora Server, and googleing I downloaded Raspberry Pi Imager and I flashed the SD where I want to install Fedora but when I insert the SD in the CB2 it doesn’t boot.

After that, I tried to install something in my VM with xubuntu without success (tried to apt-get install arm- something, or fedora- something without finding anything useful).

Which is the right way to install fedora to a cubieboard2, and which fedora version should I mount?


1 Like

FYI, I tried with rufus w/o success, always the same problem. Board stucks after 5-10s with a blinking green led 2.

I connected the UART having this informations:

HELLO! BOOT0 is starting!
boot0 version : 3.0.0
dram size =1024
Ready to disable icache.
Jump to secend Boot.
[      0.134]

U-Boot 2011.09-rc1-dirty (Nov 08 2013 - 11:06:32) Allwinner Technology

[      0.142]version: 1.1.0
[      0.145]pmbus:   ready
[      0.249]PMU: AXP209
[      0.253]PMU: AXP20x found
[      0.255]PMU: bat ratio = 100
[      0.259]after set, dcdc2 =1400mv
[      0.262]PMU: dcdc2 1400
[      0.265]PMU: pll1 912 Mhz
boot_clock = 912
dcdc2_vol = 1400
[      0.273]after set, dcdc2 =1400mv
dcdc3_vol = 1250
ldo2_vol = 3000
ldo3_vol = 2800
ldo4_vol = 2800
power_start = 0
storage_type = -1
usb_recovery = 1
find power_sply to end
fel key old mode
run key detect
no key found
no key input
dram_para_set start
dram_para_set end
[      0.309]DRAM:  1 GiB
relocation Offset is: 35b27000
donn't initialize ther user_gpio (main_key:boot_init_gpio)
DRV_DISP_Init: opened
[      0.523]boot_disp.output_type=2
[      0.526]boot_disp.output_mode=5
[      0.529]boot_disp.auto_hpd=1
workmode = 0
[      1.833]NAND: NAND_UbootInit
NB1 : enter NAND_LogicInit
nand : get id_number_ctl from script, 3
not burn nand partition table!
NB1 : nand_info_init fail
[      9.809]nand init fail
set to recovery
try sprite_led_gpio config
sprite_led_gpio start
sunxi sprite begin
screen_width = 800
screen_height = 480
bar x1: 200 y1: 200
bar x2: 600 y2: 280
read mbr failed
sprite update error: no data part found
read mbr failed
sprite update error: read image start error
sprite update error: current card sprite failed
now hold the machine
fail to find part named env
Using default environment

In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
mbr not exist
base bootcmd=run setargs_nand boot_normal
bootcmd set setargs_nand
key 0
recovery key high 6, low 4
cant find fstbt value
no misc partition is found
to be run cmd=run setargs_nand boot_normal
the part isn't exist
[      9.902]Hit any key to stop autoboot:  0
cant find part named boot
sunxi_flash - sunxi_flash sub-system

sunxi_flash read command parmeters :
parmeters 0 : addr to load(hex only)
parmeters 1 : the name of the part to be load
[parmeters 2] : the number of bytes to be load(hex only)
if [parmeters 2] not exist, the number of bytes to be load is the size of the part indecated on partemeter 1
boota: bad boot image magic, maybe not a boot.img?

Do you know what I could try?

Have you downloaded the armv7 or the aarch64 image?
If you aren’t using Fedora Linux, did you try to flash the SD card with dd?

xzcat Fedora-[edition-version].raw.xz | sudo dd status=progress bs=4M of=/dev/XXX

Where /dev/XXX is the path to the SD card.

Ciao Alessio

I didn’t have a choice, from the landing page I downloaded Fedora-Server-35-1.2.armhfp.raw.xz

I tried to download Fedora-Server-armhfp-23-10-sda.raw.xz , the same problem with Rufus.

After a couple of tricks I launched

$ xzcat Fedora-Server-35-1.2.armhfp.raw.xz | sudo dd status=progress bs=4M of=/dev/sdb
7516004352 bytes (7,5 GB, 7,0 GiB) copied, 2533 s, 3,0 MB/s

0+566918 record dentro
0+566918 record fuori
7516192768 bytes (7,5 GB, 7,0 GiB) copied, 3116,01 s, 2,4 MB/s

The serial result is the same, the HDMI print a green progress bar stuck at 10%…

Another small information, from document How To Distinguish Your CubieBoard2 Version .pdf I can’t distinguish my CubieBoard2 Version , attached photos

Btw the image linaro-14.04-desktop-cb2-card0-hdmi-v1.0.img.7z works ( 140.45 GB folder on MEGA )

Does someone know how to have an updated working version of fedora?

Here a photo for previous post, due to limitations to new users

At Fedora on Raspberry Pi :: Fedora Docs → Supported boards I can find cubieboard2

Does arm-image-installer make something more than dd or other downloadable tools for windows?

I tried also Raspberry Pi Imager , or Fedora Media Writer but the first wasn’t working and second only supports USB device.

Which path should I follow? Maybe install fedora in a USB stick and then using arm-image-installer to flash fedora into a SD?


I installed fedora workstation in a usb key, then I started it in my laptop,

then i made

sudo su
dnf -y install arm-image-installer
arm-image-installer --image=Fedora-Server-35-1.2.armhfp.raw.xz --media=/dev/mmcblk0 --target=Cubieboard2
= Selected Image:                                
= Fedora-Server-35-1.2.armhfp.raw.xz
= Selected Media : /dev/mmcblk0
= U-Boot Target : Cubieboard2
 Type 'YES' to proceed, anything else to exit now
= Proceed? YES
= Writing:
= Fedora-Server-35-1.2.armhfp.raw.xz
= To: /dev/mmcblk0 ....
7515578368 bytes (7.5 GB, 7.0 GiB) copied, 292 s, 25.7 MB/s
0+719562 records in
0+719562 records out
7516192768 bytes (7.5 GB, 7.0 GiB) copied, 349.081 s, 21.5 MB/s
= Writing image complete!
= Writing u-boot-sunxi-with-spl.bin ....
503+1 records in
503+1 records out
515252 bytes (515 kB, 503 KiB) copied, 0.0251146 s, 20.5 MB/s

= Installation Complete! Insert into the Cubieboard2 and boot.

Now the card boots but after boot HDMI get dropped (tested with two different monitor).
If I connect the eth port to my router I can reach it to the dhcp assigned ip, but logging with ssh I tested tenth of passwords without success (root/root root/toor fedora/fedora root/fedora root/fidora, etc). Which one is the right one?

Why is the HDMI not running and how can I solve it?

PS: I can see the menù with UEFI option after uboot, idk if it could help


I had a similar problem when I tried using the Fedora-Server-35-1.2.armhfp.raw.xz image on an sd card for use on my raspberry Pi.
My fix was to put the sd into my usb card reader and plug it into my daily driver. I then did a chroot to the image on the sd card and assigned root a password so it was unlocked and I could log in as root.

It seemed strange to me that the first boot did not give you the option to create a user as is done with workstation.

BTW, I did not have a problem with the hdmi on my R Pi.

I solved using uart port with a serial reader / writer. I can read and write as a normal shell, and to complete the setup.

Then I had tenth problems, now I.m installing workstation because I had an unknown network problem (that causes that the whole network falled - if I connect the device to a router all connections get dropped) and I cannot login in a local console because I disabled root. And disabling root disables also local login with other users.

Then I tried with not working how-tos regarding how to enable root access with a live cd, regarding how to mount LVM2 PV.

Everything is very funny here

Seems impossibile,

sudo arm-image-installer --image=Fedora-Workstation-35-1.2.armhfp.raw.xz --media=/dev/mmcblk0 --target=Cubieboard2

cannot boot while server edition works… Is it normal?