How to disable sound

I’m hard of hearing, and my laptop’s speakers are physically damaged anyway.

What is the cleanest way to completely disable everything to do with sound? I don’t want to see pipewire in a process list. I don’t want to see snd_* modules loaded. I don’t want any of my battery life going to sound. I don’t even want the sound amplifier energized if I can help it. (I checked and bios does not have an option to disable sound)

And someday when I move to a newer laptop I’ll probably take this hard drive with me. so I’d like to be able to undo it fairly easily.

In other words, I don’t think uninstalling the pipewire packages is a good answer because they’re a dependency of a lot of things.

Gnome desktop … top right corner, settings, move sound slider to the left => absolute silence. Otherwise in BIOS turn off boot sound.

You really can’t, and don’t want to, remove the drivers or the sound packages. Doing so is quite intrusive and may cause operational problems by having devices with no drivers loaded.

The suggestion above to simply move the volume control to the far left and just mute all sound output is far better and will have the benefit of being recoverable at any time with no problems of remembering how to reverse what you initially did to silence things.

1 Like

Whoa. I had to check just now because for a moment I wasn’t sure. Yep. I still do want to disable drivers or packages. But could such a response be any more predictable these days.

I tried blacklist=snd_hda_intel in my kernel args and the kernel swiftly ignored it.

There was a day when sound came from a physical soundblaster pci card that i could pull out, and it didn’t cause the system to not boot when I did that. Don’t tell me that Fedora needs a sound card to work or else gnome won’t start, and flames will come out. It does not.

It can 100% work without sound. The correct solution, i was hoping, was some config file in /etc/ that specified soundsubsystem=pipewire which some folks might change to pulse or alsa, or you could also set =null. But as of yet I haven’t found a setting like that.

Or disabling and masking something in systemd perhaps? Anyone know the real answer?

Anyone who doesn’t, that’s okay, no need to clutter the thread with distractions.

Most systems today have a sound card built into the mobo. If laptop that is certain. If desktop it is likely.

You can look at the back of the machine and if the sound connections are in the row with usb, network, and probably video connections then it is certain they are built into the mobo so it is impossible to disconnect the sound chipset. If it cannot be disabled within the bios then anything you do driver wise could cause problems.

If the sound chipset is built into the mobo and it cannot be disabled in bios then it is impossible to avoid it using power. The mobo is always powered as is everything built-in.

The question has a simple answer … rebuild kernel similar to HPC cluster that don’t have sound enabled removing all sound specific utilities including rebuilding Gnome. Fedora is a fast rolling release not exactly adapted, use Red Hat or CentOS server edition. For Gentoo users just business as usual … good luck with steep learning curve.

1 Like

Hi @b3y Try dconf, a super-settings app.

What about Pavucontrol?