How to boost mic volume?

In short, my microphone volume is so low it is difficult to get a good recording. Perhaps it is better to boost the volume in post-processing instead of boosting gain? I’m not sure, but I plan to look in to that.

As far as boosting mic gain, which is the traditional approach:

I set the volume slider all the way to 100%.
I checked alsamixer, it is at 100%, which is only gain +5.00
There is no mic boost slider available (usb mixer)
My soundcard has mic boost, but that doesn’t help my usb mic.

From what research I’ve done, there may be an option to use to enable mic boost, but I’m not sure what it would be for the usb mixer.

It may also be possible to create a slave device to increase the gain, but I’m not sure exactly how to do that. The examples I found weren’t very clear, especially on how to link the slave device to the primary device.

I’d really appreciate if someone could provide some clarification on these topics, or other ideas on how to get a higher volume level on my recordings.

Thanks in advance!

How did you run alsamixer ?

By default alsamixer will run on the virtual “PulseAudio” device, to be able to actual change the mixer-settings of your USB microphone you need to select the right soundcard, either running alsamixer -c # where # is 1, 2, 3, … or by pressing F6 and selecting the right soundcard. Also you can try pressing F5 to see all available controls for your USB microphone card.

If you were already controlling the right sound-card and things are still too soft then I’m afraid you are out of luck. Alsamixer controls the cards controls at the lowest level, so if that does not work, then there is not much else that you can do AFAIK.