[Un-Solved] I can't record audio from two USB devices at a time in Fedora 35

So I have two USB audio input devices, a mixer and an RCA-USB converter. Both are detected by Pipewire, both got given the same name based on the codec, and both ostenibly work. The RCA-USB converter can both receive the audio input from my gaming PC (two-PC streaming setup), and output that same audio to my speakers/headphones/etc.

The mixer (Behrenger Xenyx q802) which I use for my mic is a different story. For one, the volume is crazy low, and I had to raise it a lot higher on my mixer to see any real input in the Sound settings menu.

The second, more serious problem with the mixer is that while apps seem to detect it, they can’t record from it. OBS in particular has this problem. Audacity records nothing at all. The RCA-USB converter works fine, everything records okay.

But the mic? Not so much. Annoyingly, I unpluged the RCA-USB converter, and the mic started being usable in OBS. I plugged the converter back in, and suddenly it just wouldn’t play nice. The way I figure it, both devices are showing up in apps as the same device, and whichever one loaded in first is getting priority.

In the sound menu, they show up separately, and both work.


I installed pavucontrol, and they both seem to work there as well, but still with those low volume issues.

1 Like

Hi, first may be you want to check with your microphone if it need phantom power (usually have range up to 48v) or not .

Also maybe you want to check from terminal and type alsamixer, then press F6 to select your devices. If your devices available there it will give some volume slider controls. Find if there any “Mic Boost” slider. You could try to rise it.

The phantom power is on. But I’ll try the alsamixer thing, thanks.

I’ve managed to solve the problem, at least temporarily, by routing the audio manually with Helvum. Wish there was a way to just make things work right automatically though. Programs still don’t seem to recognize on of my USB devices as an option unless I route the audio manually.

1 Like

And I solved the problem again, with maybe the dumbest method out there. I noticed, while looking around, that both USB audio devices were on the same internal USB “interface”. So I plugged my mixer into the other side of the computer. Everything is now working as it should. But man, that’s a bug that needs fixing.

[Update:] Annnnd then it stopped working again. I need a way to separate the two devices.

1 Like

Since both of devices you want to connect to OBS are detected by Helvum means the Pipewire detect it as different device. I’m not sure but probably the OBS should detect it as different device too.

Would you like to try:

  1. From OBS Audio Mixer, click gear icon of “Mic/Aux”, select “Properties” then select the first USB interface device.

  2. From OBS studio on Sources, add new (+) source, select “Audio Input Capture (PulseAudio)”. Then from part “Audio Mixer”, for newly added source click the gear icon then select “Properties” then from the “Device” drop down select your second USB interface device.

From step 2 we create “Audio Input Capture (PulseAudio)” even we are not using PulseAudio and Pipewire have compability setting to do this.

If above successfully connected, you could check with Helvum and you could find that both devices are connected to OBS.

Thanks for the suggestion. I tried that and it didn’t work… though I could always give it another shot.

In the end I disabled wireplumber and installed Pulseaudio. I renamed the devices in question via the CLI, and now everything works as it darned well should. I’m done with wireplumber until it actually works.