How I can I install ibus-engine in Silverblue

How can I install an ibus-engine, which have no rpm package (I usually install it with make install ) in silverblue. I’m talking about https://github.com/sarim/ibus-avro this ibus-engine for inputting Bangla.

I’ve tried making rpm with checkinstall, but failed to install with message saying gschema.compiled already exists and some hardlinking error. I’ve tried using --prefix=/usr/local but that too failed with message saying /usr/local isn’t supported.

Which option do I have? I can install it in toolbox and can’t run outside toolbox and since the engine must operate with the system level daemon, how can I acheive it?

I’m very new to Silverblue, docker, container thing (Only a few days now) but I think, I’ve got the big picture. But couldn’t figure out this. Am I missing any obvious ?

I’ve originally posted this on ask.fedoraproject and got no answer . https://ask.fedoraproject.org/t/how-can-i-install-ibus-engine-in-silverblue/2783

Hmm, so where was /usr/local not supported? As for checkinstall, it seems to require running make install manually, so that’s probably a no-go here

That message was shown when I changed the --prefix to /usr/local since when used /usr it says there is already a gschema.compiled exists.

I just installed this into /usr/local without much issue, although I compiled it inside Flatpak (don’t ask)

You may have to delete /usr/local/share/glib-2.0/schemas/gschemas.compiled

Inside flatpak or inside toolbox? I can install it inside toolbox. But that won’t be usable outside of it

I installed it on the host.

1 Like

Oh, that’s good. Can you input Bengali using Avro phonetic then? Please share the process. I’m new to flatpak packaging.