High number of Selinux issues after upgrading to Fedora 36

Maybe I misunderstand your post but In the grub menu (or at least the menu I can see before my system starts up), the first 3 kernels are fc34 ones and the “rescue” one is fc31, which should be the one I initially installed.

I’m not sure to understand

Here’s the output of sudo cat /boot/efi/EFI/fedora/grub.cfg:

search --no-floppy --fs-uuid --set=dev 88634689-721c-42f6-b814-287fa850a72e
set prefix=($dev)/grub2
export $prefix
configfile $prefix/grub.cfg

Here’s the output of sudo ls /boot/efi/EFI:

BOOT  fedora

Does not seem right based on /etc/grub.d/10_reset_boot_success

So you mean I did something wrong or do you just find it strange?

Don’t worry, I’m the one not understanding in this case.

No, don’t think anyone did anything wrong.

But I am confused on how boot_indeterminate would get set to 7.

I can only find it in the below script, and can’t seem to find it anywhere else. That’s not to say it’s wrong, I’m just not sure how it got there

 ### BEGIN /etc/grub.d/10_reset_boot_success ###
# Hiding the menu is ok if last boot was ok or if this is a first boot attempt to boot the entry
if [ "${boot_success}" = "1" -o "${boot_indeterminate}" = "1" ]; then
  set menu_hide_ok=1    
  set menu_hide_ok=0 
# Reset boot_indeterminate after a successful boot
if [ "${boot_success}" = "1" ] ; then
  set boot_indeterminate=0
# Avoid boot_indeterminate causing the menu to be hidden more than once
elif [ "${boot_indeterminate}" = "1" ]; then
  set boot_indeterminate=2 
# Reset boot_success for current boot 
set boot_success=0
save_env boot_success boot_indeterminate
### END /etc/grub.d/10_reset_boot_success ###

So what do you suggest?

Have you tried re-installing grub?

sudo dnf reinstall grub2-efi grub2-common

I’m at a loss here…

I just tried, thad didn’t work… :frowning:
Should I try to update grub? How to update Grub on RHEL or CentOS Linux - #2 by monk - Linux - nixCraft Linux/Unix Forum

No, you can rebuild grub:
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

That post is out of date based on Changes/UnifyGrubConfig - Fedora Project Wiki

Is this still the case with your grub menu?


I just tried the command, it said that another entry was created for the bios to use, but when I rebooted I still had the same grub menu (with 5.12.9-300.fc34 one or older ones), and upon checking in the BIOS it still proposed the same entries as before.

I should mention at this point that my BIOS lists two identical named fedora entries to boot on (and I can’t remember for how long It’s been like that, I never fiddled with the boot process of my distro), and I’ve already tried to boot each of these but they both lead to the grub screen abovementionned). Also present is an entry which leads to a broken grub, complaining about the filesystem or something. I also have a windows entry to boot on, and a broken entry (Realtek, which shouldn’t be something bootable).
Now that I think of it, I think I did a clean reinstall of windows (on my secondary drive) about a year ago and that since (I think) the grub screen (the two identical ones) are not able to boot windows (as proposed at the bottom of the menu) anymore. This timeframe might correspond to the version of kernel which I seem to be stuck with (or maybe it’s a coincidence).

Can you check
sudo efibootmgr -v
sudo blkid

Wondering if you’re EFI partition ended up somewhere else.


Here’s the output of sudo efibootmgr -v:

BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0001,0002,0006,0005,0007
Boot0001* Fedora	HD(2,MBR,0xfa7bdeb8,0x186a0800,0x12c000)/File(\EFI\fedora\shimx64.efi)
Boot0002* UEFI OS	HD(2,MBR,0xfa7bdeb8,0x186a0800,0x12c000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot0004* Fedora	HD(2,MBR,0xfa7bdeb8,0x186a0800,0x12c000)/File(\EFI\FEDORA\shimx64.efi)
Boot0005* Windows Boot Manager	HD(1,GPT,f40b1bc0-be1b-4f45-9107-2e7cb03c6493,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...h................
Boot0006* Hard Drive 	BBS(HD,,0x0)..GO..NO........o.K.I.N.G.S.T.O.N. .S.A.4.0.0.S.>..Gd-.;.A..MQ..L. . . . ........BO..NO........y.M.a.s.s. .S.t.o.r.a.g.e. .D.e.v.i.c.e. .1...0.0....................A.............................F..Gd-.;.A..MQ..L.M.a.s.s. .S.t.o.r.a.g.e. .D.e.v.i.c.e. .1...0.0........BO
Boot0007* Network Card 	BBS(Network,,0x0)..GO..NO........k.R.e.a.l.t.e.k. .P.X.E. .B.0.5. .D.0.0.........................rN.D+..,.\...........<..Gd-.;.A..MQ..L.R.e.a.l.t.e.k. .P.X.E. .B.0.5. .D.0.0........BO

And the output of sudo blkid:

/dev/loop1: TYPE="squashfs"
/dev/mapper/fedora_localhost--live-root: UUID="9e1101c5-10a6-437d-aa3d-e3eb318ea0b1" BLOCK_SIZE="4096" TYPE="ext4"
/dev/loop8: TYPE="squashfs"
/dev/sdb4: BLOCK_SIZE="512" UUID="0AA8DB49A8DB3245" TYPE="ntfs" PARTUUID="423c4cb2-ab27-4291-9d57-1260a84e84ea"
/dev/sdb2: PARTLABEL="Microsoft reserved partition" PARTUUID="b51975cc-5961-4e5f-8bd0-9addee89c9ec"
/dev/sdb3: BLOCK_SIZE="512" UUID="2CE830CCE83095D4" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="91e4bda5-f4a6-4293-8d02-cc3d4a498b99"
/dev/sdb1: UUID="BA2E-BDE5" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f40b1bc0-be1b-4f45-9107-2e7cb03c6493"
/dev/mmcblk0: LABEL_FATBOOT="Datasheets" LABEL="Datasheets" UUID="1F79-0554" BLOCK_SIZE="512" TYPE="vfat"
/dev/loop15: TYPE="squashfs"
/dev/loop6: TYPE="squashfs"
/dev/loop13: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop11: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/mapper/fedora_localhost--live-swap: UUID="036529b3-080e-4c8b-87e0-70c54ae84509" TYPE="swap"
/dev/loop0: TYPE="squashfs"
/dev/mapper/luks-dc093f83-04a1-45bd-8d69-0386733b29d1: UUID="rhlTnX-Tz3J-ylbZ-hsOA-mrRy-GIyL-jnLuRW" TYPE="LVM2_member"
/dev/loop9: TYPE="squashfs"
/dev/loop16: TYPE="squashfs"
/dev/loop7: TYPE="squashfs"
/dev/sda2: UUID="95C4-4619" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="fa7bdeb8-02"
/dev/sda5: UUID="dc093f83-04a1-45bd-8d69-0386733b29d1" TYPE="crypto_LUKS" PARTUUID="fa7bdeb8-05"
/dev/sda3: UUID="88634689-721c-42f6-b814-287fa850a72e" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="fa7bdeb8-03"
/dev/sda1: LABEL="Storage" BLOCK_SIZE="512" UUID="4472565B47B79351" TYPE="ntfs" PARTUUID="fa7bdeb8-01"
/dev/loop14: TYPE="squashfs"
/dev/zram0: LABEL="zram0" UUID="3318314d-0ffe-4dfc-bda0-e1d51aec364c" TYPE="swap"
/dev/loop5: TYPE="squashfs"
/dev/loop12: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/mapper/fedora_localhost--live-home: UUID="7f0c1a08-8751-4bf2-a63f-e4b016bf638b" BLOCK_SIZE="4096" TYPE="ext4"
/dev/loop10: TYPE="squashfs"

Can you also post
mount | grep -i boot


mount | grep -i bootgives:

/dev/sda2 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)

and lsblk gives:

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
loop0                                           7:0    0     4K  1 loop  /var/lib/snapd/snap/bare/5
loop1                                           7:1    0 111.7M  1 loop  /var/lib/snapd/snap/core/13250
loop2                                           7:2    0  61.9M  1 loop  /var/lib/snapd/snap/core20/1328
loop3                                           7:3    0  55.5M  1 loop  /var/lib/snapd/snap/core18/2284
loop4                                           7:4    0  61.9M  1 loop  /var/lib/snapd/snap/core20/1494
loop5                                           7:5    0  55.5M  1 loop  /var/lib/snapd/snap/core18/2409
loop6                                           7:6    0 161.4M  1 loop  /var/lib/snapd/snap/gnome-3-28-1804/128
loop7                                           7:7    0 164.8M  1 loop  /var/lib/snapd/snap/gnome-3-28-1804/161
loop8                                           7:8    0 217.9M  1 loop  /var/lib/snapd/snap/gnome-3-34-1804/60
loop9                                           7:9    0   219M  1 loop  /var/lib/snapd/snap/gnome-3-34-1804/77
loop10                                          7:10   0 248.8M  1 loop  /var/lib/snapd/snap/gnome-3-38-2004/99
loop11                                          7:11   0  65.2M  1 loop  /var/lib/snapd/snap/gtk-common-themes/1519
loop12                                          7:12   0  81.3M  1 loop  /var/lib/snapd/snap/gtk-common-themes/1534
loop13                                          7:13   0 113.8M  1 loop  /var/lib/snapd/snap/mc-installer/577
loop14                                          7:14   0 119.6M  1 loop  /var/lib/snapd/snap/mc-installer/588
loop15                                          7:15   0  44.7M  1 loop  /var/lib/snapd/snap/snapd/15904
loop16                                          7:16   0  12.3M  1 loop  /var/lib/snapd/snap/vobsub2srt/34
sda                                             8:0    0 447.1G  0 disk  
├─sda1                                          8:1    0 195.3G  0 part  
├─sda2                                          8:2    0   600M  0 part  /boot/efi
├─sda3                                          8:3    0     1G  0 part  
├─sda4                                          8:4    0     1K  0 part  
└─sda5                                          8:5    0 250.2G  0 part  
  └─luks-dc093f83-04a1-45bd-8d69-0386733b29d1 253:0    0 250.2G  0 crypt 
    ├─fedora_localhost--live-root             253:1    0    70G  0 lvm   /
    ├─fedora_localhost--live-swap             253:2    0   7.8G  0 lvm   [SWAP]
    └─fedora_localhost--live-home             253:3    0 172.4G  0 lvm   /home
sdb                                             8:16   0 119.2G  0 disk  
├─sdb1                                          8:17   0   100M  0 part  
├─sdb2                                          8:18   0    16M  0 part  
├─sdb3                                          8:19   0 118.6G  0 part  
└─sdb4                                          8:20   0   499M  0 part  
sdc                                             8:32   1     0B  0 disk  
mmcblk0                                       179:0    0  29.7G  0 disk  
zram0                                         252:0    0     8G  0 disk  [SWAP]
1 Like

If you didn’t read the whole topic, the cause of the problem has been identified but unsolved: my system doesn’t use the latest kernel although it is installed as the grub startup menu only proposes old fc34 ones.

I don’t have any additional ideas, my recommendation would be to back everything up and reinstall at this point.

1 Like

I reinstalled.
Thanks everyone for trying, it was an honour to have some SELinux devs answering
I’m gonna mark the “wrong kernel” answer as the good one, even though it didn’t solve the problem it pointed out the actual problem.

1 Like