Help to use Fedora Silverblue: drivers

Dear collaborators,

I am quite new to using Silverblue, I intend to use it as a platform for teaching and developing projects. Therefore, I would like to ask this forum.

I have a very limited notebook that goes with the configuration below. I need this notebook to use a Bluetooth USB Dongle for the Bluetooth wireless devices (keyboard and mouse) and use the Droidcam for webcam transmission of my mobile phone.

A few days ago I did some tests with the toolbox to install Droidcam but I was not very successful.

I leave the links to Droidcam and Bluetooth available

If anyone needs any information, please let me know what I need to do.

Thank you very much.

Dioclecio

Hello @dioclecio,
Welcome to the discussion forum. You should look here first for info on using bluetooth devices on Fedora, which is same for SB. https://fedoraproject.org/wiki/Documentation/Bluetooth Let us know how it goes.
Also, the current stable release of Fedora Silverblue is F33 which uses linux kernel 5.8.18 as of todays update.

Dear Jack,

I tried. But when I put the dongle into the USB, I receive the following message:

[47418.755160] Bluetooth: hci1: RTL: examining hci_ver=0a hci_rev=000b lmp_ver=0a lmp_subver=8761
[47418.756146] Bluetooth: hci1: RTL: rom_version status=0 version=1
[47418.756152] Bluetooth: hci1: RTL: loading rtl_bt/rtl8761b_fw.bin
[47418.760446] bluetooth hci1: Direct firmware load for rtl_bt/rtl8761b_fw.bin failed with error -2
[47418.760457] Bluetooth: hci1: RTL: firmware file rtl_bt/rtl8761b_fw.bin not found

But It is not allowed to put this driver into this system folder.

Yours,

Dioclecio

For debugging, you can use rpm-ostree usroverly which will mount a temporary writable overlay on top of /usr that will allow you to place a firmware there. If this works, then you should probably report a bug upstream to the kernel directly or through the Fedora kernel bugs.

Dear Siosm,

It worked using the usroverlay. And the result is this:

[ 2896.809662] Bluetooth: hci1: RTL: examining hci_ver=0a hci_rev=000b lmp_ver=0a lmp_subver=8761
[ 2896.810687] Bluetooth: hci1: RTL: rom_version status=0 version=1
[ 2896.810693] Bluetooth: hci1: RTL: loading rtl_bt/rtl8761b_fw.bin
[ 2896.812093] Bluetooth: hci1: RTL: loading rtl_bt/rtl8761b_config.bin
[ 2896.812228] Bluetooth: hci1: RTL: cfg_sz 6, total sz 20522
[ 2896.922632] Bluetooth: hci1: RTL: fw version 0x0999646b

I think its not permanent. But I will try to open a bug for Fedora Silverblue.

Thank you.

This is great! Yes, changes made using usroverlay are not permanent.

Please open a bug targeting the Fedora kernel (in Component) in bugzilla so that it gets properly tracked.

1 Like

hi Siosm,

I opened a call, but unfortunately it was not understood or healed.

I ended up returning to Fedora Workstation. Silverblue is very interesting, but it has these limitations with drivers that make it difficult to use.

But the project is interesting.
Thanks for the answers.

Can you link the bug here? Thanks