[Help] Installing Fedora on external SSD > wth am I doing wrong

I’ve been trying to install linux for the third day now.
I found this distro was quite popular and decided to do this instead of my botchedd mint installation.

I’ve loaded into anaconda from an external SSD that I flashed the iso on.
the SSD now has 2 paritions. one is unallocated space.

Ideally I’d like to utilize that unallocated space and install the fedora OS on.

On Fedora 40 installer.

It only shows “local standard disk” as my internal drive 2gb
I tried format the unallocated SSD parition to NTFS 2TB.
I tried different formats.
Even though the disk manager in anaconda recognizes the drive sometimes able to mount it.

The installer still doesnt populate the external SSD drive partition whether its unallocated space or formatted into NTFS or Linux.

It only shows internal drive as available drive to be installed on.

What am I doing wrong?

Hello @kelestios ,
I think that it would help to run the installer again this time select troubleshooting and go to a command prompt. From there we can look at what the installer actually sees for hardware. It may be easier to try to make a live usb system with persistence on your external usb drive and select to boot it from the BIOS boot menu. Instructions for that can be found at Creating and using a live installation image :: Fedora Docs. If you need some help with it, myself or others here may be able to assist.

Normally the installer is written to a USB key. The layout is a bit tricky because it needs to support BIOS and UEFI boot configurations. Any remaining space on the target USB storage is unavailable. You can’t install Fedora onto the installer USB because that would necessarily overwrite the existing layout and render the installer unusable.

1 Like

I would not try to install Fedora on the same disk you put the installer on. Put the installer on an USB key.


Say I have SSD 1 as the installer.

What format should SSD 2 be, to be recognized by the installer fedora 40 on SSD1?

Can SSD 2 be partitioned?
Partition 1 for the OS & Partition 2 for Data storage.

Both SSD(s) 1& 2 are external.

You first need to put the installer on a usb key as already noted. It only needs to be about 4GB in size since that fits the install media ISO.

You then need to use gdisk or similar in a terminal window to restore the partitioning on the SSD to default (write a new blank GPT partition table to that device) which should now allow writing to it again. When you wrote the install iso onto that device it then seemed as if it were only the 2GB is09660 image as the entire device (and is not writable). An empty partition table should remove that limitation.

Finally you can do an installation to the SSD by booting from the USB with both devices attached and select the ssd as the destination for the installation.

Also, running a full desktop from a USB drive is a horrible experience. I would link other threads and post about this very topic, but would rather just say “I strongly discourage it”.

A full desktop IMO should NOT be on an external drive.

1 Like

Say I have SSD 1 as the installer.

What format should SSD 2 be, to be recognized by the installer fedora 40 on SSD1?

Can SSD 2 be partitioned?
Partition 1 for the OS & Partition 2 for Data storage.

Both SSD(s) 1& 2 are external.

I had SSD 2 as NTFS with data on it on the live run in anaconda before,
and it refused to populate SSD 2 as “Local Disk” in the installer of Fedora 40

  1. You must have unallocated space available to install fedora. If it already had data on it then you first may need to remove the partitioning on that device which can usually be done by using ‘gdisk’ in a terminal window and create a new empty gpt partition table.
    Using ‘lsblk’ should show every attached device and allow you to select SSD 2 to wipe the old data and create the new empty partition table.

  2. What you show as SSD1 should actually be a usb flash drive of 4 GB or larger size where you wrote the ISO image and booted the live image (installer).

  3. If you are using SSD 2 as the one where you previously had the ISO image written then you must restore the default factory config. After writing that image to it the system now sees it as a RO ISO9660 file system and cannot use it for writing (and it would not show as a device to which the OS could be installed). That is where the instructions in step 1 apply as well.

1 Like

That should be “is often a horrible …”. I have a 2012 iMac with a slow (laptop) internal hard disk. An nvme drive in a USB3 case boots faster and generally out performs the internal hard disk by a factor of 2.

At work we replaced SGI workstations running Photoshop with Mac Pro’s (filled with high-end hard disks), then added iMacs (2012-2015) . Users were not happy with the performace of iMac hard disks, and found external high-end hard disks in firewire cases were much faster.

Huge variables here. You’re using desktop grade hardware in an enclosure. You are effectively maxing out that USB3 bandwdith limit of around 500MB/s (Sata6Gb/s) where as the “Best” HDD’s of the day 2012 were around 175MB/s.

The cache on your Enclosed drive is roughly 10x larger than the cache on a circa 2012 HDD.
NVMe cache’s trend upto 1GB(1028MB), whereas HDD “Best in Class” 128MB. . .

Which is my point in every thread here about such devices. The layman will say :

:person_curly_hair:t5: : I have a USB3 drive should be good enough.
:person_curly_hair:t5: :thought_balloon: : I bought this Knockoff 64GB thumb drive off the internet, it only has 24MB cache. . . Should be good enough for :fedora:

This takes the cake.
Cleaning the drive with CMD on win11 allowed an unallocated space for Fedora 40 Installer to be installed.

I clean the drive (SSD2)
made a GPT partition.
Used Disk manager to seperate a partition for data storage.
left like 300gb as allocated space.

Used SSD1 as the live run installer.
Installed fedora on SS2 unallocated.

Thanks! I appreciate your insight!