Hello how can I install Oracle database on Fedora 36 I have tried but can't?

I have downloaded the RPM file from the official website but when I want to install it, it doesn’t even let me install the preinstallation :frowning: HELP

Welcome to ask.fedora @jaimed-m

Please have a look at #start-here to see how to create a topic with enough and useful information to get the attention to your issue.

I get this message: “This category is moderated. Only site staff can post here, Please use Ask Category for this purpose”

You were not being asked to post there, but rather to review the posts there and see what info may be useful for getting assistance.

We need several bits of info, including the name of the site you downloaded the DB from, the name and version of the DB if available, the system you are using and its current update status and release version in use, as well as any other information you think may be useful for us to be able to form a useful suggestion for solving your issue.

We also need in detail the error messages you may have received.

1 Like

First I downloaded the preinstallation file from the official website but when I want to install it I get the following message:

And the same thing happens with the database RPM file that I also downloaded from the official site.

Page of the steps I am following: https://docs.oracle.com/en/database/oracle/oracle-database/21/xeinl/installing-oracle-database-xe.html#GUID-46EA860A-AAC4-453F-8EEE-42CC55A4FAD5

I suspect that Fedora Linux is not supported by Oracle database. Supported systems are Redhat Enterprice Linux and SUSE Enterprice Linux and of course Oracles own version of Redhat. It might work on Centos.

I got the same error you did.
A quick search for the preinstall package led me to this site, which tells you the process.

However, even after downloading and attempting to install the preinstall package I get this

 Problem: conflicting requests
  - nothing provides xorg-x11-utils needed by oracle-database-preinstall-19c-1.0-1.el7.x86_64
  - nothing provides compat-libcap1 needed by oracle-database-preinstall-19c-1.0-1.el7.x86_64
  - nothing provides compat-libstdc++-33 needed by oracle-database-preinstall-19c-1.0-1.el7.x86_64

It seems you must be downloading from an oracle repo to get those packages – or at least on a linux version that has the compatible packages available, which is not fedora 36.

Then I will have to install another database :frowning: Thanks for the help.

There are 2 different databases that are native to fedora. Postgresql and mariadb. There is also a very basic ‘sqlite’ db in use for a lot of different things.

Both have a lot of good features even though they may not be fully up to enterprise quality. I have and do use both for different purposes.

1 Like

Thanks for the input on how to do that install. :+1:

Everyone needs to be aware that although this worked there is always a potential that updating fedora after performing this may break the oracle software. Just a cautionary note since the software is not from fedora directly.

I also note that the tag on this thread says f36 which has been EOL for almost a year and is not receiving any updates, including no security updates.
The thread has been idle for a year with no updates so I doubt that you are actually using f36.

Please post your info on a new thread, telling us the hardware and fedora version you are using so readers are able to see the actual context instead of basing your input on an old EOL release of fedora.