HDMI not working (is it because of a recent update to silverblue?)

Hello everyone,

Recently my HDMI doesn’t seem to work.
On the television’s end it’s fine. It even detects that “something” is connected but not outputting a signal.
When I open up display or sound settings, my laptop doesn’t detect an external screen or sound output.
I’m not sure how this could have happened, it was working only a few days ago.
The only thing I could think of was an update did this. I rolled back and it didn’t fix it, probably because if it was an update it was from before the rollback.
Is the best way for me to see if I can fix this to reset to the original?
Any suggestions?

Thanks in advance!

I guess because of the release of fedora 34 very soon, have been made a lot of changes. So maybe you have to go back more as one version ?!

This here might help you to roll back definitely:
Updates, Upgrades & Rollbacks :: Fedora Docs

1 Like

Thanks for this!

Maybe that is the case, I was thinking of resetting sudo rpm-ostree reset

And then reinstalling all my packages (not many).

Was also wondering if it would be worth it, since we’re so close to Fedora 34 stable, should I expect an update to come in that’ll just fix it?

Also, how do you access the grub menu?

I think it is the same as on a normal Fedora Linux … pressing ESC while booting.

If you try to fix you have an idea if it is simple or not. Fedora Linux changes fast. And to know how to help your self is always an advantage. To make the decision is up to you.

1 Like

I assumed it broke because of an update but I could be wrong. In my mind the hope was another update any day could fix it.

I tried the “sudo rpm-ostree reset” and went back and that didn’t seem to fix it.

I have been having difficulty with the HDMI out from my desktop for a couple of releases of SB now. The HDMI monitor is recognized by the system, and it realizes it’s connected to something, but no video joy. I haven’t investigated my issue though.

It’s recognised by the system? Like, the computer? Or recognised from the television.

I was using rawhide before and switched to the beta. I’m not sure if this is why it stopped working.

Yes, the computer “sees” the HDMI monitor so when I do xrandr -q I get the following output …

Screen 0: minimum 16 x 16, current 2646 x 768, maximum 32767 x 32767
XWAYLAND0 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768      59.62*+
   1024x768      59.68  
   800x600       59.47  
   640x480       59.38  
   320x240       59.52  
   720x480       59.71  
   640x400       59.20  
   320x200       58.96  
   1280x720      59.65  
   1024x576      59.58  
   864x486       59.45  
   720x400       59.55  
   640x350       58.91  
XWAYLAND1 connected 1280x720+1366+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x720      59.86*+
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77

Okay, so on my end, I was just very silly.

I tried different HDMI cables to no avail, but using a different port seems to have “fixed” it.

That is to say it was never broken.