Guayadeque; wxsqlite Problem

I have a small problem updating with Guayadeque Music Player which requires a certain dependency but is offered to me via update.
Here is my output:

root@fedora:/home/jag# dnf up
Fedora 36 - x86_64 - updates 12 kB/s | 15 kB 00:01    
Fedora 36 - x86_64 - updates 636 kB/s | 2.4 MB 00:03    
Fedora Modular 36 - x86_64 - Updates 20 kB/s | 19 kB 00:00    
google-chrome 4.0 kB/s | 1.3 kB 00:00    
RPM Fusion for Fedora 36 - Free tainted 29 kB/s | 7.0 kB 00:00    
RPM Fusion for Fedora 36 - Free - Updates 10 kB/s | 6.8 kB 00:00    
Dependencies are resolved.

 Problem: package guayadeque-0.4.7-0.38.20220801gita8b47a6.fc36.x86_64 requires, but none of the providers can be installed
  - cannot install both wxsqlite3-4.8.2-5.fc36.x86_64 and wxsqlite3-4.5.1-5.fc36.x86_64
  - cannot install the best update candidate for package wxsqlite3-4.5.1-5.fc36.x86_64
  - cannot install the best update candidate for package guayadeque-0.4.7-0.38.20220801gita8b47a6.fc36.x86_64
 package architecture version package source size
 SDL2 x86_64 2.24.0-1.fc36 updates 661 k
 tumbler x86_64 4.16.1-1.fc36 updates 236 k
 xfce4-screenshooter x86_64 1.9.11-1.fc36 updates 294 k
 xfce4-screenshooter-plugin x86_64 1.9.11-1.fc36 updates 49 k
Packages with conflicts are skipped:
(add "--best --allowerasing" to the command line to force the update):
 wxsqlite3 x86_64 4.8.2-5.fc36 updates 842 k

Transaction summary
Update 4 packages
Skip 1 package

Total download size: 1.2 M
Is this ok? [y/N]: n

Where can I report the problem?

Did you try that suggested fix?

Are you not aware that some packages do not get populated to 100% of the mirrors at the same time thus inconsistencies may occur that will be resolved over time as the mirrors receive their updates?

The fix is to either use the suggested workaround or to wait a few hours or days then redo the update and the problem usually is automatically fixed.

Yes, I can skip and hope that it will be fixed.
The problem occurred over the weekend, so it’s not that urgent.

I only ask where I can best report such problems.

I’ll say it right now: Guayadeque working was the main reason for me to switch to Fedora in the first place since OpenSuse couldn’t get it working, sad but true.
But I will wait a few days since I always do my updates on the weekend anyway.

But thanks for your feedback.


If it is only a technical issue that can be solved by information or configuration this is the best place. If it is actually a bug most of us can help triage it then advise if a bug should be filed.

1 Like

Wie du es schon angesprochen hast hat sich das Problem von alleine erledigt. Ob ich mit meinen Post dazu Beigetragen habe oder nicht ist egal.

Auf jeden Fall ist eine neue Version von Guayadeque und von wxsqlite beim Update dabei. Ich habe ein bisschen getestet und es scheint alles in Ordnung zu sein.

Ich bedanke mich an alle die daran beteiligt waren auch denen ganz weit im Hintergrund.

Auf Englisch hier, bitte. Vielleicht, wir auch brauchen ein Channel auf Deutsch.

I have been running Guayadeque on Fedora 36 without any trouble until
yesterday, and now it can’t find a shared library. So I decided to rebuild
Guayadeque from source. The build failed because some headers had
moved, and I worked around that by adding a symbolic link. I’m wondering
if I should file a bug for this?

The following works for building Guayadeque on Fedora 36 (including this
new workaround):

$ sudo ln -s /usr/include/wx-3.1/wx /usr/include/wx

$ sudo yum groupinstall “Development Tools”
$ sudo yum install cmake gcc-c++ gettext wxGTK wxGTK-devel taglib-devel sqlite-devel
libcurl-devel gnutls-devel dbus-devel flac-devel libgpod-devel subversion subversion-libs
wxsqlite3 wxsqlite3-devel jsoncpp-devel

$ mkdir guayadeque
$ cd guayadeque
$ git clone GitHub - anonbeat/guayadeque: Guayadeque is a music management program designed for all music enthusiasts. It is Full Featured Linux media player that can easily manage large collections and uses the Gstreamer media framework.
$ cd guayadeque
$ ./build
$ sudo make install

As you have already mentioned, the problem has resolved itself. Whether I contributed to it with my post or not doesn’t matter.

In any case, a new version of Guayadeque and of wxsqlite is included in the update. I tested a bit and everything seems to be ok.

I thank all who have been involved also those far in the background.

I hope it is better that way.

1 Like

Glad you found a solution. Some things to keep in mind:

  • You’ll need to rebuild it on each new release to update it and should also do so after upgrade to a new Fedora version
  • Make sure to have the dnf version uninstalled because they will likely conflict
  • Make sure to install it to /usr/local or /opt instead of /usr out of concern for conflicting on system stuff
  • Consider using a toolbox environment for this as a further extra precaution against conflicting with system installed stuff

Lastly, as @mustermann suggested, a patch has already been done in dnf, which I would certainly recommend using over building from source for this.

I just tried the dnf version and it works great. I will use that instead. Thanks for your help!

1 Like