Gstreamer1-plugin-openh264 fails to download; Curl error (28)

I have a system with Fedora 36 server installed, and wanted to get a desktop environment going. It seemed straight forward enough, but so far I’ve not had much luck getting the package to install.

I tried a repo install, “sudo dnf install '@'kde-desktop-environment” (and "dnf group install “KDE Plasma Workspaces”)

It progresses as expected, but then stalls on openh264

[MIRROR] gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64.rpm: Curl error (28): Timeout was reached for [Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds]

(425/1002): blivet-data-3.4.4-1.fc36.noarch.rpm 143 kB/s | 110 kB 00:00

[FAILED] gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success

(427-428/1002): openh264-2.3.1- 26% [======== ] 560 kB/s | 254 MB 21:14 ETA

The downloaded packages were saved in cache until the next successful transaction.

You can remove cached packages by executing ‘dnf clean packages’.

Error: Error downloading packages:

gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64: Cannot download, all mirrors were already tried without success

I tried direct wget of the .rpm file, but that times out


–2023-10-11 20:14:14--

Resolving (…,, 2600:1405:7400:f::17d9:94b, …

Connecting to (||:80… connected.

HTTP request sent, awaiting response…

I also tried installing gstreamer, but the same stall happens (operation too slow).

dnf install gstreamer1-plugin-openh264 mozilla-openh264

Any pointers on where the issue is, and how I can potentially get around it?

Fedora 36 is EOL, you can search in the archive if you find the package you are looking for and install it manually.

Best would be to upgrade to the stable version (F38). And later to F39 where gets released soon.

1 Like

You might also be able to install just that package.
dnf install gstreamer1-plugin-openh264

Note that package comes directly from cisco and since fedora 36 is EOL and has been for almost 6 months it seems possible that cisco no longer provides for the older fedora versions.

Upgrading to a currently supported version is always recommended. F37 will also be EOL in about a month.