Graphics glitches in the upper right corner button of windows

On the upper right corner of all my windows there are supposed to be three buttons: one to minimize the window, the next to maximize it, the next to close it.

At the beginning there was only the one to close it, then I personalized my PC with the order I described using this command:

gsettings set org.gnome.desktop.wm.preferences button-layout ":minimize,maximize,close"

It worked fine until at least two days ago, but this is how I see those buttons now


As you can see, I see a cloud of points instead of the actual buttons.

This happens in ALL windows except the ones that use the QT toolkit, like TexStudio, for which I have other glitches.

The screenshot was taken from Gedit, and it happens also in Firefox and in the file manager (Nautilus).

How can I solve the problem and restore the correct graphics for those buttons?

Apparently it’s connected with the “Arc” theme I am using and that I have installed from the official repositories.

Using GNOME Tweak Tool to swtich to the “Adwaita” theme has this graphical glitch solved.

1 Like

I would report a bug on the Arc theme since it is reproducible. Are you on Fedora 34? if so then gnome 40 would likely be the issue.

1 Like

dnf info arc-theme gives you the link to github: