Gparted install but requires root privileges to open, doesnt ask for pw

hi, sorry to ask again, installed fedora 37 with cinnamon DE, installed gparted, tried from software center, terminal and dnfdragora, all seem to install, appears in menu, but when trying to start it says requires root priviledges and will not start, does not ask for pw, fails in terminal also. i did some searching, maybe something to do with policies, everything else seems to work fine ( have used cinnamon for years with mint and ubuntu remix, so quite familiar with it, second time trying fedora so not much experience there)

tks, but I am not running gnome, I am running cinnamon, and it always works
in mint and ubuntu, so should work in fedora without a custom launcher, but tks for your feedback

It used to work, but since the latest updates of gparted, it requires root to run.

Of course, changelog and updateinfo didn’t mention that.

1 Like

Reading this I just tried it and mine also needs root.I haven’t used it in awhile so I don’t know when it changed.Changing to root in terminal then typing gparted started it.

t hank you for the replies, yes I got it running in terminal now, but still wont run from cinnamon menu. not sure what I did, reinstalled it a couple different ways and it finally ran with root privileges. anyway, I 'll wait for an update now that it runs from terminal. tks for the suggestions.

1 Like

Looking more closely at the source files, it seems that this was a building mistake, and the change was not intentional.

On gnome it pops up the authentication window. The password I use is my user password since that actually seems to use sudo for authentication. No root password required, only the users password. (The user must be able to use sudo!)

This is the same behavior as using VMM for VM management, and it does exactly the same.

As I stated I haven’t used it in awhile so I don’t know when or what update caused it to change.I’m running Fedora 38 now and saw the post today so I checked and it says it must be opened by root.There is no popup for a password.The only way I could start it was in the terminal as root.

I have not tried it with F38. With F37 Workstation it works as expected.

Maybe you should file a bug?

I, too, am running f37 Workstation, fully updated, and using Gnome. When I try to run gparted from the launcher, I now get a popup panel informing me that it now must be started as root; it no longer prompts for a password to allow sudo.

This is a fairly recent change, since I used it less than a week ago.

@jrredho & @straycat

If this is the same popup you see then it uses the users password.
Screenshot from 2023-04-04 11-49-52

I just did an update for testing purposes and the popup now shows
Screenshot from 2023-04-04 12-01-19

Packages updated were

Packages Altered:
    Upgrade  fakeroot-1.31-1.fc37.x86_64                         @updates
    Upgraded fakeroot-1.30.1-1.fc37.x86_64                       @@System
    Upgrade  fakeroot-libs-1.31-1.fc37.x86_64                    @updates
    Upgraded fakeroot-libs-1.30.1-1.fc37.x86_64                  @@System
    Upgrade  fwupd-1.8.14-1.fc37.x86_64                          @updates
    Upgraded fwupd-1.8.12-1.fc37.x86_64                          @@System
    Upgrade  fwupd-plugin-flashrom-1.8.14-1.fc37.x86_64          @updates
    Upgraded fwupd-plugin-flashrom-1.8.12-1.fc37.x86_64          @@System
    Upgrade  fwupd-plugin-modem-manager-1.8.14-1.fc37.x86_64     @updates
    Upgraded fwupd-plugin-modem-manager-1.8.12-1.fc37.x86_64     @@System
    Upgrade  fwupd-plugin-uefi-capsule-data-1.8.14-1.fc37.x86_64 @updates
    Upgraded fwupd-plugin-uefi-capsule-data-1.8.12-1.fc37.x86_64 @@System
    Upgrade  gdb-13.1-2.fc37.x86_64                              @updates
    Upgraded gdb-13.1-1.fc37.x86_64                              @@System
    Upgrade  gdb-headless-13.1-2.fc37.x86_64                     @updates
    Upgraded gdb-headless-13.1-1.fc37.x86_64                     @@System
    Upgrade  gegl04-0.4.44-1.fc37.x86_64                         @updates
    Upgraded gegl04-0.4.38-1.fc37.x86_64                         @@System
    Upgrade  ghostscript-9.56.1-6.fc37.x86_64                    @updates
    Upgraded ghostscript-9.56.1-5.fc37.x86_64                    @@System
    Upgrade  ghostscript-tools-fonts-9.56.1-6.fc37.x86_64        @updates
    Upgraded ghostscript-tools-fonts-9.56.1-5.fc37.x86_64        @@System
    Upgrade  ghostscript-tools-printing-9.56.1-6.fc37.x86_64     @updates
    Upgraded ghostscript-tools-printing-9.56.1-5.fc37.x86_64     @@System
    Upgrade  gnome-maps-43.5-1.fc37.x86_64                       @updates
    Upgraded gnome-maps-43.4-1.fc37.x86_64                       @@System
    Upgrade  gnome-shell-43.4-1.fc37.x86_64                      @updates
    Upgraded gnome-shell-43.3-1.fc37.x86_64                      @@System
    Upgrade  gparted-1.5.0-1.fc37.x86_64                         @updates
    Upgraded gparted-1.4.0-2.fc37.x86_64                         @@System
    Upgrade  gssdp-1.4.1-1.fc37.x86_64                           @updates
    Upgraded gssdp-                         @@System
    Upgrade  gupnp-1.4.4-1.fc37.x86_64                           @updates
    Upgraded gupnp-1.4.3-3.fc37.x86_64                           @@System
    Upgrade  gvfs-1.50.4-1.fc37.x86_64                           @updates
    Upgraded gvfs-1.50.3-1.fc37.x86_64                           @@System
    Upgrade  gvfs-afc-1.50.4-1.fc37.x86_64                       @updates
    Upgraded gvfs-afc-1.50.3-1.fc37.x86_64                       @@System
    Upgrade  gvfs-afp-1.50.4-1.fc37.x86_64                       @updates
    Upgraded gvfs-afp-1.50.3-1.fc37.x86_64                       @@System
    Upgrade  gvfs-archive-1.50.4-1.fc37.x86_64                   @updates
    Upgraded gvfs-archive-1.50.3-1.fc37.x86_64                   @@System
    Upgrade  gvfs-client-1.50.4-1.fc37.x86_64                    @updates
    Upgraded gvfs-client-1.50.3-1.fc37.x86_64                    @@System
    Upgrade  gvfs-fuse-1.50.4-1.fc37.x86_64                      @updates
    Upgraded gvfs-fuse-1.50.3-1.fc37.x86_64                      @@System
    Upgrade  gvfs-goa-1.50.4-1.fc37.x86_64                       @updates
    Upgraded gvfs-goa-1.50.3-1.fc37.x86_64                       @@System
    Upgrade  gvfs-gphoto2-1.50.4-1.fc37.x86_64                   @updates
    Upgraded gvfs-gphoto2-1.50.3-1.fc37.x86_64                   @@System
    Upgrade  gvfs-mtp-1.50.4-1.fc37.x86_64                       @updates
    Upgraded gvfs-mtp-1.50.3-1.fc37.x86_64                       @@System
    Upgrade  gvfs-smb-1.50.4-1.fc37.x86_64                       @updates
    Upgraded gvfs-smb-1.50.3-1.fc37.x86_64                       @@System
    Upgrade  libgs-9.56.1-6.fc37.x86_64                          @updates
    Upgraded libgs-9.56.1-5.fc37.x86_64                          @@System
    Upgrade  libkworkspace5-5.27.3-3.fc37.x86_64                 @updates
    Upgraded libkworkspace5-5.27.3-2.fc37.x86_64                 @@System
    Upgrade  libldb-2.6.2-1.fc37.x86_64                          @updates
    Upgraded libldb-2.6.1-1.fc37.x86_64                          @@System
    Upgrade  libsemanage-3.5-2.fc37.x86_64                       @updates
    Upgraded libsemanage-3.5-1.fc37.x86_64                       @@System
    Upgrade  libsmbclient-2:4.17.7-0.fc37.x86_64                 @updates
    Upgraded libsmbclient-2:4.17.6-0.fc37.x86_64                 @@System
    Upgrade  libwbclient-2:4.17.7-0.fc37.x86_64                  @updates
    Upgraded libwbclient-2:4.17.6-0.fc37.x86_64                  @@System
    Upgrade  mutter-43.4-1.fc37.x86_64                           @updates
    Upgraded mutter-43.3-2.fc37.x86_64                           @@System
    Upgrade  openexr-libs-3.1.6-1.fc37.x86_64                    @updates
    Upgraded openexr-libs-3.1.5-2.fc37.x86_64                    @@System
    Upgrade  plasma-workspace-common-5.27.3-3.fc37.x86_64        @updates
    Upgraded plasma-workspace-common-5.27.3-2.fc37.x86_64        @@System
    Upgrade  publicsuffix-list-20230318-1.fc37.noarch            @updates
    Upgraded publicsuffix-list-20210518-5.fc37.noarch            @@System
    Upgrade  publicsuffix-list-dafsa-20230318-1.fc37.noarch      @updates
    Upgraded publicsuffix-list-dafsa-20210518-5.fc37.noarch      @@System
    Upgrade  python3-libsemanage-3.5-2.fc37.x86_64               @updates
    Upgraded python3-libsemanage-3.5-1.fc37.x86_64               @@System
    Upgrade  python3-pytz-2023.3-1.fc37.noarch                   @updates
    Upgraded python3-pytz-2023.2-1.fc37.noarch                   @@System
    Upgrade  qpdf-libs-10.6.3-5.fc37.x86_64                      @updates
    Upgraded qpdf-libs-10.6.3-4.fc37.x86_64                      @@System
    Upgrade  samba-client-2:4.17.7-0.fc37.x86_64                 @updates
    Upgraded samba-client-2:4.17.6-0.fc37.x86_64                 @@System
    Upgrade  samba-client-libs-2:4.17.7-0.fc37.x86_64            @updates
    Upgraded samba-client-libs-2:4.17.6-0.fc37.x86_64            @@System
    Upgrade  samba-common-2:4.17.7-0.fc37.noarch                 @updates
    Upgraded samba-common-2:4.17.6-0.fc37.noarch                 @@System
    Upgrade  samba-common-libs-2:4.17.7-0.fc37.x86_64            @updates
    Upgraded samba-common-libs-2:4.17.6-0.fc37.x86_64            @@System
    Upgrade  systemd-251.14-2.fc37.x86_64                        @updates
    Upgraded systemd-251.13-6.fc37.x86_64                        @@System
    Upgrade  systemd-boot-unsigned-251.14-2.fc37.x86_64          @updates
    Upgraded systemd-boot-unsigned-251.13-6.fc37.x86_64          @@System
    Upgrade  systemd-container-251.14-2.fc37.x86_64              @updates
    Upgraded systemd-container-251.13-6.fc37.x86_64              @@System
    Upgrade  systemd-devel-251.14-2.fc37.x86_64                  @updates
    Upgraded systemd-devel-251.13-6.fc37.x86_64                  @@System
    Upgrade  systemd-libs-251.14-2.fc37.i686                     @updates
    Upgraded systemd-libs-251.13-6.fc37.i686                     @@System
    Upgrade  systemd-libs-251.14-2.fc37.x86_64                   @updates
    Upgraded systemd-libs-251.13-6.fc37.x86_64                   @@System
    Upgrade  systemd-networkd-251.14-2.fc37.x86_64               @updates
    Upgraded systemd-networkd-251.13-6.fc37.x86_64               @@System
    Upgrade  systemd-oomd-defaults-251.14-2.fc37.noarch          @updates
    Upgraded systemd-oomd-defaults-251.13-6.fc37.noarch          @@System
    Upgrade  systemd-pam-251.14-2.fc37.x86_64                    @updates
    Upgraded systemd-pam-251.13-6.fc37.x86_64                    @@System
    Upgrade  systemd-resolved-251.14-2.fc37.x86_64               @updates
    Upgraded systemd-resolved-251.13-6.fc37.x86_64               @@System
    Upgrade  systemd-rpm-macros-251.14-2.fc37.noarch             @updates
    Upgraded systemd-rpm-macros-251.13-6.fc37.noarch             @@System
    Upgrade  systemd-udev-251.14-2.fc37.x86_64                   @updates
    Upgraded systemd-udev-251.13-6.fc37.x86_64                   @@System
    Upgrade  tigervnc-license-1.13.1-3.fc37.noarch               @updates
    Upgraded tigervnc-license-1.13.1-1.fc37.noarch               @@System
    Upgrade  tigervnc-server-minimal-1.13.1-3.fc37.x86_64        @updates
    Upgraded tigervnc-server-minimal-1.13.1-1.fc37.x86_64        @@System
    Upgrade  webp-pixbuf-loader-0.2.4-1.fc37.x86_64              @updates
    Upgraded webp-pixbuf-loader-0.2.2-1.fc37.x86_64              @@System

This change does not seem reasonable on workstation which by default has no root access except with sudo and the change makes it harder for the average user to manage the system. The earlier method seems to provide the same security.

1 Like

It should be a bug in the latest package version, so downgrading can help until the issue is resolved:

sudo dnf downgrade gparted

Or use the following workaround to customize the launcher:

mkdir -p ~/.local/bin
tee ~/.local/bin/gparted << "EOF" > /dev/null
pkexec env DISPLAY="${DISPLAY}" \
    XAUTHORITY="${XAUTHORITY}" /usr/bin/gparted "${@}"
chmod +x ~/.local/bin/gparted
desktop-file-install \
--dir=${HOME}/.local/share/applications \
--set-key=Exec \
--set-value="gparted %f" \

It follows the XDG specification and should work across DEs, although you may need to relogin to apply changes.

1 Like

The change in the latest version compared to the previous is

--- usr/bin/gparted	2022-07-21 15:00:22.000000000 +0200
+++ /usr/bin/gparted	2023-03-25 12:32:53.000000000 +0100
@@ -50,7 +50,7 @@
 	#  non-root to display the graphical error about needing root
 	#  privileges.
-	if test "xpkexec --disable-internal-agent" = "x"; then
+	if test "x" = "x"; then
 		echo "Root privileges are required for running gparted."
 		exit 1
@@ -75,7 +75,7 @@
 	# Run gparted as root.
-	pkexec --disable-internal-agent '/usr/bin/gparted' "$@"
+	 '/usr/bin/gparted' "$@"

Note that the new version does not know about the pkexec command.

The previous version is gparted-1.4.0-2.fc37.x86_64 which don’t have the problem

The latest version can work with pkexec if started with the proper environment variables.

just had to log out and in. Now it works as always.
With your changes done of course.

thank you again for all the replies, it works for me now from command line so will wait until its updated. but little confusing for a new linux user. tks again for your attention

Before or after downgrading to the older version?

The bug has just been fixed a few hours ago. You cat get it at

and before long it would show up in updates-testing.

1 Like