GNOME Software "The name is not activatable"


I am quite new here; sorry if this is the wrong place to post these kinds of questions. While refreshing updates available via the GNOME Software Center, I get an error message “Unable to get list of updates” because of “The name is not activatable” (see screenshot).

I’ve tried to find information about the issue but can’t find anything related to it. This bug report, for example, doesn’t seem to be related to my problem at all. All I can find is this Reddit post where someone seems to have the same issue as I do. I could see if I can find anything in the logs, but I am a bit unsure of what log files to look at. Does anyone have any idea?



Yeah, I ran across this too. See this upstream bug:


It appears you are using the gnome software app to do the update. Try using a terminal and from the command line run

 sudo dnf upgrade 

If that works you are good. Sometimes there are packages installed that are not handled by the gnome software app since it uses a different source for the updates and often there are errors of this type because of lags in having the repos synced. Two different causes but similar messages.

1 Like

Might be, but the error message appears way before the software app has actually finished polling available updates. And I am still able to update via the app, no problems, it’s just that this message keeps appearing.


I have the same issue, both with an upgrade from Fedora 32 to Fedora 33, and a straight up fresh Fedora 33 install.

I’ve tried the post-upgrade tasks explained here: DNF System Upgrade :: Fedora Docs

It’s not a big deal, but to me there are 2 main issues:

  • This bug happens even from a fresh install
  • The message is far from easy to understand

Hi. I don’t know if this information will work. But maybe it happen to you too. I have the same problem. It started about half a month ago. At the same time I started having a problem with the repositories.

Sobe Vivaldi, I don’t know what happened. It is the first time that it happens. But what I wanted you to see is that it gives an error in updates
I have tried doing dnf clean all and then dnf makecahce and it fixes it. Also try what creak said.But then the next day it happens again.

Note that if you are using the gnome software app that those commands using dnf do not affect the cache or configs used by the app. DNF and the app are 2 different tools trying to do similar work – one from the command line and one by gui. They do not match.


I have the same issue…I just installed Fedora 33 :frowning:

A fix is on the way. So just ignore the message for now…