Gnome Files - Failed to launch "directory", could not activate remote peer

The application Files in Gnome doesn’t open correctly, after some recent update.

When I try to open directly the app from the applications list, the application name appear for some seconds in the top bar with a loading spinner, then disappear.
If I try to directly choose a location from the “Places” short-cut that Gnome created for me in the top bar, a notification appears saying “Failed to launch ‘directory’. Could not activate remote peer”, then nothing happens.

I tried removing and the reinstalling the application using Gnome Software, nothing changed.

I haven’t installed nothing new recently, I have only updated the system.

Welcome to ask.:fedora:edora @luckv

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Please also try to start the app in a terminal. You can find the command in the properties of the app while right clicking on it and see the properties.
Starting from terminal should give you more information what could be wrong.

  Kernel: 5.16.15-201.fc35.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME 41.4 Distro: Fedora release 35 (Thirty Five)
  Type: Laptop System: ASUSTeK product: X510UQ v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X510UQ v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X510UQ.310 date: 04/19/2019
  ID-1: BAT0 charge: 22.4 Wh (73.2%) condition: 30.6/42.1 Wh (72.7%)
    volts: 11.5 min: 11.5 model: ASUSTeK ASUS Battery status: Not charging
  Info: dual core model: Intel Core i7-7500U bits: 64 type: MT MCP
    arch: Amber/Kaby Lake note: check rev: 9 cache: L1: 128 KiB L2: 512 KiB
    L3: 4 MiB
  Speed (MHz): avg: 1066 high: 1877 min/max: 400/3500 cores: 1: 1877
    2: 1116 3: 674 4: 600 bogomips: 23199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: ASUSTeK driver: nvidia
    v: 470.103.01 bus-ID: 01:00.0
  Device-3: IMC Networks VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:3
  Display: wayland server: X.Org v: with: Xwayland v: 21.1.4
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.16.15-201.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 704.24 GiB used: 82.47 GiB (11.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB
  ID-1: / size: 127.98 GiB used: 63.24 GiB (49.4%) fs: btrfs dev: /dev/dm-0
    mapped: luks-f5756105-859f-4b8a-b009-e4ffe21cb20e
  ID-2: /boot size: 973.4 MiB used: 204.1 MiB (21.0%) fs: ext4
    dev: /dev/sda4
  ID-3: /boot/efi size: 1.86 GiB used: 14 MiB (0.7%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: zram size: 7.64 GiB used: 32.2 MiB (0.4%)
    dev: /dev/zram0
  System Temperatures: cpu: 44.0 C pch: 37.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 2600
  Processes: 353 Uptime: 1d 9h 43m Memory: 7.64 GiB used: 4.08 GiB (53.4%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 38
  note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.13
$ nautilus
nautilus: error while loading shared libraries: /lib64/ cannot read file data: Error 21

Is it correct, nautilus is the command to launch gnome files?

Searching the error I found this stackoverflow question that seems related to my problem.

I launched these commands, and seems that the library that nautilus needs, is under /usr/lib64 and not under /lib64.


The variable $LD_LIBRARY_PATH isn’t set.

$ sudo ldconfig
ldconfig: Cannot mmap file /lib64/

ldconfig: File /lib64/ is empty, not checked.
ldconfig: Cannot mmap file /lib64/

ldconfig: File /lib64/ is empty, not checked.
ldconfig: File /lib64/ is empty, not checked.
ldconfig: Cannot mmap file /lib64/

ldconfig: File /lib64/ is empty, not checked.
$ sudo find / -name
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied

I tried to add the path /usr/lib64 to $LD_LIBRARY_PATH, but the error remained, this time with the path where the library were found with find.

$ export LD_LIBRARY_PATH=/usr/lib64
$ nautilus
nautilus: error while loading shared libraries: /usr/lib64/ cannot read file data: Error 21

/lib64 is a symbolic link to /usr/lib64, and that is the default library search path, so setting LD_LIBRARY_PATH to the latter doesn’t do anything except change the output text a little.

These files should not be empty. It sounds like your previous update failed somehow, and some files were corrupted. For all of these files, you should find the package to which they belong:

$ rpm -qf /lib64/
$ rpm -qf /lib64/
$ rpm -qf /lib64/

and then re-install them:

$ sudo dnf reinstall gnome-autoar libnsl libuv

You may also want to check your update history with sudo dnf history list and sudo dnf history info or maybe logs (journalctl) to check whether more packages in the previous updates were broken.

$ rpm -qf /lib64/ 
$ rpm -qf /lib64/ 
$ rpm -qf /lib64/

dnf history list gives me this command, launched on May 19th

dnf -y install --disablerepo=* /tmp/akmods.jf0YMJpt/results/kmod-nvidia-470xx-5.16.15-201.fc35.x86_64-470.103.01-1.fc35.x86_64.rpm 

Launched probably with a software update from the Software Center.

The output of sudo dnf history info has one transaction, the number 109, that report those errors. It’s the one found previously.

$ sudo dnf history info 109
Transaction ID : 109
Begin time     : Sat 19 Mar 2022 10:23:31 CET
Begin rpmdb    : e20d22f7b99200d030e7517ea31bfbb279504208
End time       : Sat 19 Mar 2022 10:23:42 CET (11 seconds)
End rpmdb      : 3a98718785c30652d4553ac52a35c9bad228198a
User           : System <unset>
Return-Code    : Success
Releasever     : 35
Command Line   : -y install --disablerepo=* /tmp/akmods.jf0YMJpt/results/kmod-nvidia-470xx-5.16.15-201.fc35.x86_64-470.103.01-1.fc35.x86_64.rpm
Comment        : 
Packages Altered:
    Install kmod-nvidia-470xx-5.16.15-201.fc35.x86_64-3:470.103.01-1.fc35.x86_64 @@commandline
Scriptlet output:
   1 /sbin/ldconfig: Cannot mmap file /lib64/
   3 /sbin/ldconfig: File /lib64/ is empty, not checked.
   4 /sbin/ldconfig: Cannot mmap file /lib64/
   6 /sbin/ldconfig: File /lib64/ is empty, not checked.
   7 /sbin/ldconfig: File /lib64/ is empty, not checked.
   8 /sbin/ldconfig: Cannot mmap file /lib64/
  10 /sbin/ldconfig: File /lib64/ is empty, not checked.
  11 /sbin/ldconfig: Cannot mmap file /lib64/
  13 /sbin/ldconfig: File /lib64/ is empty, not checked.
  14 /sbin/ldconfig: Cannot mmap file /lib64/
  16 /sbin/ldconfig: File /lib64/ is empty, not checked.
  17 /sbin/ldconfig: File /lib64/ is empty, not checked.
  18 /sbin/ldconfig: Cannot mmap file /lib64/
  20 /sbin/ldconfig: File /lib64/ is empty, not checked.

I think I’ve found the guilty transaction, the number 102. Contains the update of all the three “empty” libraries: gnome-autoar, libnsl, libuv. Reports as Return-Code failure, and as End Time 01 Jan 1970… strange. My pc was always turned on when I applied updates, so I don’t think this error is related to missing power supply.

$ sudo dnf history info 102
Transaction ID : 102
Begin time     : Fri 18 Mar 2022 11:30:59 CET
Begin rpmdb    : 2133:8b1aa59558e5fe8c64f94a6cc1f33ab4f08b08ed
End time       : Thu 01 Jan 1970 01:00:00 CET (-1647599459 seconds)
End rpmdb      : 
User           : root <root>
Return-Code    : Failure: 1
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  kernel-5.16.13-200.fc35.x86_64                                      @updates
    Install  kernel-core-5.16.13-200.fc35.x86_64                                 @updates
    Install  kernel-devel-5.16.13-200.fc35.x86_64                                @updates
    Install  kernel-modules-5.16.13-200.fc35.x86_64                              @updates
    Install  kernel-modules-extra-5.16.13-200.fc35.x86_64                        @updates
    Upgrade  aardvark-dns-1.0.1-2.fc35.x86_64                                    @updates
    Upgrade  crun-1.4.3-1.fc35.x86_64                                            @updates
    Upgrade  cups-filters-1.28.12-1.fc35.x86_64                                  @updates
    Upgrade  cups-filters-braille-1.28.12-1.fc35.x86_64                          @updates
    Upgrade  cups-filters-libs-1.28.12-1.fc35.x86_64                             @updates
    Upgrade  cyrus-sasl-2.1.27-14.fc35.x86_64                                    @updates
    Upgrade  cyrus-sasl-gssapi-2.1.27-14.fc35.x86_64                             @updates
 ** Upgrade  cyrus-sasl-lib-2.1.27-14.fc35.i686                                  @updates
    Upgrade  cyrus-sasl-lib-2.1.27-14.fc35.x86_64                                @updates
    Upgrade  cyrus-sasl-plain-2.1.27-14.fc35.x86_64                              @updates
    Upgrade  firefox-98.0-2.fc35.x86_64                                          @updates
    Upgrade  flexiblas-3.1.3-1.fc35.x86_64                                       @updates
    Upgrade  flexiblas-netlib-3.1.3-1.fc35.x86_64                                @updates
    Upgrade  flexiblas-openblas-openmp-3.1.3-1.fc35.x86_64                       @updates
 ** Upgrade  glibc-2.34-28.fc35.i686                                             @updates
    Upgrade  glibc-2.34-28.fc35.x86_64                                           @updates
    Upgrade  glibc-all-langpacks-2.34-28.fc35.x86_64                             @updates
    Upgrade  glibc-common-2.34-28.fc35.x86_64                                    @updates
    Upgrade  glibc-devel-2.34-28.fc35.x86_64                                     @updates
 ** Upgrade  glibc-gconv-extra-2.34-28.fc35.i686                                 @updates
    Upgrade  glibc-gconv-extra-2.34-28.fc35.x86_64                               @updates
    Upgrade  glibc-headers-x86-2.34-28.fc35.noarch                               @updates
    Upgrade  glibc-langpack-en-2.34-28.fc35.x86_64                               @updates
    Upgrade  glibc-langpack-it-2.34-28.fc35.x86_64                               @updates
    Upgrade  gnome-autoar-0.4.3-1.fc35.x86_64                                    @updates
    Upgrade  gnome-tweaks-40.10-1.fc35.noarch                                    @updates
    Upgrade  ibus-typing-booster-2.15.25-1.fc35.noarch                           @updates
    Upgrade  iwl100-firmware-                           @updates
    Upgrade  iwl1000-firmware-1:                        @updates
    Upgrade  iwl105-firmware-                          @updates
    Upgrade  iwl135-firmware-                          @updates
    Upgrade  iwl2000-firmware-                         @updates
    Upgrade  iwl2030-firmware-                         @updates
    Upgrade  iwl3160-firmware-1:                       @updates
    Upgrade  iwl3945-firmware-                          @updates
    Upgrade  iwl4965-firmware-                        @updates
    Upgrade  iwl5000-firmware-                         @updates
    Upgrade  iwl5150-firmware-                           @updates
    Upgrade  iwl6000-firmware-                          @updates
    Upgrade  iwl6000g2a-firmware-                      @updates
    Upgrade  iwl6000g2b-firmware-                      @updates
    Upgrade  iwl6050-firmware-                          @updates
    Upgrade  iwl7260-firmware-1:                       @updates
    Upgrade  iwlax2xx-firmware-20220310-130.fc35.noarch                          @updates
    Upgrade  liberation-fonts-1:2.1.5-1.fc35.noarch                              @updates
    Upgrade  liberation-fonts-common-1:2.1.5-1.fc35.noarch                       @updates
    Upgrade  liberation-mono-fonts-1:2.1.5-1.fc35.noarch                         @updates
    Upgrade  liberation-sans-fonts-1:2.1.5-1.fc35.noarch                         @updates
    Upgrade  liberation-serif-fonts-1:2.1.5-1.fc35.noarch                        @updates
    Upgrade  libertas-usb8388-firmware-2:20220310-130.fc35.noarch                @updates
 ** Upgrade  libnsl-2.34-28.fc35.i686                                            @updates
    Upgrade  libnsl-2.34-28.fc35.x86_64                                          @updates
    Upgrade  libuv-1:1.44.1-1.fc35.x86_64                                        @updates
 ** Upgrade  libvdpau-1.5-1.fc35.i686                                            @updates
    Upgrade  libvdpau-1.5-1.fc35.x86_64                                          @updates
    Upgrade  linux-firmware-20220310-130.fc35.noarch                             @updates
    Upgrade  linux-firmware-whence-20220310-130.fc35.noarch                      @updates
    Upgrade  netavark-1.0.1-1.fc35.x86_64                                        @updates
 ** Upgrade  pipewire-0.3.48-1.fc35.i686                                         @updates
 ** Upgrade  pipewire-0.3.48-1.fc35.x86_64                                       @updates
 ** Upgrade  pipewire-alsa-0.3.48-1.fc35.i686                                    @updates
 ** Upgrade  pipewire-alsa-0.3.48-1.fc35.x86_64                                  @updates
 ** Upgrade  pipewire-gstreamer-0.3.48-1.fc35.x86_64                             @updates
 ** Upgrade  pipewire-jack-audio-connection-kit-0.3.48-1.fc35.x86_64             @updates
 ** Upgrade  pipewire-libs-0.3.48-1.fc35.i686                                    @updates
 ** Upgrade  pipewire-libs-0.3.48-1.fc35.x86_64                                  @updates
 ** Upgrade  pipewire-pulseaudio-0.3.48-1.fc35.x86_64                            @updates
 ** Upgrade  pipewire-utils-0.3.48-1.fc35.x86_64                                 @updates
    Upgrade  python3-packaging-21.3-2.fc35.noarch                                @updates
    Upgrade  python3-regex-2022.3.2-1.fc35.x86_64                                @updates
    Upgrade  tracker-miners-3.2.2-1.fc35.x86_64                                  @updates
    Upgrade  vim-data-2:8.2.4529-1.fc35.noarch                                   @updates
    Upgrade  vim-minimal-2:8.2.4529-1.fc35.x86_64                                @updates
 ** Upgrade  wireplumber-0.4.8-2.fc35.x86_64                                     @updates
 ** Upgrade  wireplumber-libs-0.4.8-2.fc35.x86_64                                @updates
    Upgrade  code-1.65.2-1646927812.el7.x86_64                                   @code
    Upgrade                                @docker-ce-stable
    Upgrade  docker-ce-3:20.10.13-3.fc35.x86_64                                  @docker-ce-stable
    Upgrade  docker-ce-cli-1:20.10.13-3.fc35.x86_64                              @docker-ce-stable
    Upgrade  docker-ce-rootless-extras-20.10.13-3.fc35.x86_64                    @docker-ce-stable
    Upgrade  docker-scan-plugin-0.17.0-3.fc35.x86_64                             @docker-ce-stable
 ** Upgraded kernel-5.16.9-200.fc35.x86_64                                       @@System
 ** Upgraded kernel-core-5.16.9-200.fc35.x86_64                                  @@System
 ** Upgraded kernel-devel-5.16.9-200.fc35.x86_64                                 @@System
 ** Upgraded kernel-modules-5.16.9-200.fc35.x86_64                               @@System
 ** Upgraded kernel-modules-extra-5.16.9-200.fc35.x86_64                         @@System
 ** Removed  kmod-nvidia-470xx-5.16.9-200.fc35.x86_64-3:470.103.01-1.fc35.x86_64 @@System
 ** Upgraded aardvark-dns-1.0.0-1.fc35.x86_64                                    @@System
 ** Upgraded crun-1.4.2-1.fc35.x86_64                                            @@System
 ** Upgraded cups-filters-1.28.11-1.fc35.x86_64                                  @@System
 ** Upgraded cups-filters-braille-1.28.11-1.fc35.x86_64                          @@System
 ** Upgraded cups-filters-libs-1.28.11-1.fc35.x86_64                             @@System
 ** Upgraded cyrus-sasl-2.1.27-13.fc35.x86_64                                    @@System
 ** Upgraded cyrus-sasl-gssapi-2.1.27-13.fc35.x86_64                             @@System
 ** Upgraded cyrus-sasl-lib-2.1.27-13.fc35.i686                                  @@System
 ** Upgraded cyrus-sasl-lib-2.1.27-13.fc35.x86_64                                @@System
 ** Upgraded cyrus-sasl-plain-2.1.27-13.fc35.x86_64                              @@System
 ** Upgraded firefox-97.0.1-2.fc35.x86_64                                        @@System
 ** Upgraded flexiblas-3.1.2-1.fc35.x86_64                                       @@System
 ** Upgraded flexiblas-netlib-3.1.2-1.fc35.x86_64                                @@System
 ** Upgraded flexiblas-openblas-openmp-3.1.2-1.fc35.x86_64                       @@System
 ** Upgraded glibc-2.34-25.fc35.i686                                             @@System
 ** Upgraded glibc-2.34-25.fc35.x86_64                                           @@System
 ** Upgraded glibc-all-langpacks-2.34-25.fc35.x86_64                             @@System
 ** Upgraded glibc-common-2.34-25.fc35.x86_64                                    @@System
 ** Upgraded glibc-devel-2.34-25.fc35.x86_64                                     @@System
 ** Upgraded glibc-gconv-extra-2.34-25.fc35.i686                                 @@System
 ** Upgraded glibc-gconv-extra-2.34-25.fc35.x86_64                               @@System
 ** Upgraded glibc-headers-x86-2.34-25.fc35.noarch                               @@System
 ** Upgraded glibc-langpack-en-2.34-25.fc35.x86_64                               @@System
 ** Upgraded glibc-langpack-it-2.34-25.fc35.x86_64                               @@System
 ** Upgraded gnome-autoar-0.4.2-1.fc35.x86_64                                    @@System
 ** Upgraded gnome-tweaks-40.0-4.fc35.noarch                                     @@System
 ** Upgraded ibus-typing-booster-2.15.16-1.fc35.noarch                           @@System
 ** Upgraded iwl100-firmware-                           @@System
 ** Upgraded iwl1000-firmware-1:                        @@System
 ** Upgraded iwl105-firmware-                          @@System
 ** Upgraded iwl135-firmware-                          @@System
 ** Upgraded iwl2000-firmware-                         @@System
 ** Upgraded iwl2030-firmware-                         @@System
 ** Upgraded iwl3160-firmware-1:                       @@System
 ** Upgraded iwl3945-firmware-                          @@System
 ** Upgraded iwl4965-firmware-                        @@System
 ** Upgraded iwl5000-firmware-                         @@System
 ** Upgraded iwl5150-firmware-                           @@System
 ** Upgraded iwl6000-firmware-                          @@System
 ** Upgraded iwl6000g2a-firmware-                      @@System
 ** Upgraded iwl6000g2b-firmware-                      @@System
 ** Upgraded iwl6050-firmware-                          @@System
 ** Upgraded iwl7260-firmware-1:                       @@System
 ** Upgraded iwlax2xx-firmware-20220209-129.fc35.noarch                          @@System
 ** Upgraded liberation-fonts-1:2.1.4-2.fc35.noarch                              @@System
 ** Upgraded liberation-fonts-common-1:2.1.4-2.fc35.noarch                       @@System
 ** Upgraded liberation-mono-fonts-1:2.1.4-2.fc35.noarch                         @@System
 ** Upgraded liberation-sans-fonts-1:2.1.4-2.fc35.noarch                         @@System
 ** Upgraded liberation-serif-fonts-1:2.1.4-2.fc35.noarch                        @@System
 ** Upgraded libertas-usb8388-firmware-2:20220209-129.fc35.noarch                @@System
 ** Upgraded libnsl-2.34-25.fc35.i686                                            @@System
 ** Upgraded libnsl-2.34-25.fc35.x86_64                                          @@System
 ** Upgraded libuv-1:1.43.0-2.fc35.x86_64                                        @@System
 ** Upgraded libvdpau-1.4-6.fc35.i686                                            @@System
 ** Upgraded libvdpau-1.4-6.fc35.x86_64                                          @@System
 ** Upgraded linux-firmware-20220209-129.fc35.noarch                             @@System
 ** Upgraded linux-firmware-whence-20220209-129.fc35.noarch                      @@System
 ** Upgraded netavark-1.0.0-1.fc35.x86_64                                        @@System
 ** Upgraded pipewire-0.3.47-1.fc35.i686                                         @@System
 ** Upgraded pipewire-0.3.47-1.fc35.x86_64                                       @@System
 ** Upgraded pipewire-alsa-0.3.47-1.fc35.i686                                    @@System
 ** Upgraded pipewire-alsa-0.3.47-1.fc35.x86_64                                  @@System
 ** Upgraded pipewire-gstreamer-0.3.47-1.fc35.x86_64                             @@System
 ** Upgraded pipewire-jack-audio-connection-kit-0.3.47-1.fc35.x86_64             @@System
 ** Upgraded pipewire-libs-0.3.47-1.fc35.i686                                    @@System
 ** Upgraded pipewire-libs-0.3.47-1.fc35.x86_64                                  @@System
 ** Upgraded pipewire-pulseaudio-0.3.47-1.fc35.x86_64                            @@System
 ** Upgraded pipewire-utils-0.3.47-1.fc35.x86_64                                 @@System
 ** Upgraded python3-packaging-21.0-2.fc35.noarch                                @@System
 ** Upgraded python3-regex-2022.1.18-1.fc35.x86_64                               @@System
 ** Upgraded tracker-miners-3.2.1-1.fc35.x86_64                                  @@System
 ** Upgraded vim-data-2:8.2.4485-1.fc35.noarch                                   @@System
 ** Upgraded vim-minimal-2:8.2.4485-1.fc35.x86_64                                @@System
 ** Upgraded wireplumber-0.4.8-1.fc35.x86_64                                     @@System
 ** Upgraded wireplumber-libs-0.4.8-1.fc35.x86_64                                @@System
 ** Upgraded code-1.65.0-1646220750.el7.x86_64                                   @@System
 ** Upgraded                                @@System
 ** Upgraded docker-ce-3:20.10.12-3.fc35.x86_64                                  @@System
 ** Upgraded docker-ce-cli-1:20.10.12-3.fc35.x86_64                              @@System
 ** Upgraded docker-ce-rootless-extras-20.10.12-3.fc35.x86_64                    @@System
 ** Upgraded docker-scan-plugin-0.12.0-3.fc35.x86_64                             @@System

libnsl package was not available… whatever this means. In fact only libnsl now appears in the output of sudo ldconfig, the other 2 libraries were fixed, and nautilus open correctly.

$ sudo dnf reinstall gnome-autoar libnsl libuv
Last metadata expiration check: 0:23:54 ago on Mon 21 Mar 2022 22:58:06 CET.
Installed package libnsl-2.34-25.fc35.x86_64 (from updates) not available.
Installed package libnsl-2.34-28.fc35.x86_64 (from updates) not available.
Installed package libnsl-2.34-28.fc35.i686 (from updates) not available.
Dependencies resolved.
 Package                                                             Architecture                                                  Version                                                                 Repository                                                      Size
 gnome-autoar                                                        x86_64                                                        0.4.3-1.fc35                                                            updates                                                         59 k
     replacing  gnome-autoar.x86_64 0.4.2-1.fc35
 libuv                                                               x86_64                                                        1:1.44.1-1.fc35                                                         updates                                                        150 k
     replacing  libuv.x86_64 1:1.43.0-2.fc35

Transaction Summary

Total download size: 209 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): libuv-1.44.1-1.fc35.x86_64.rpm                                                                                                                                                                                                           553 kB/s | 150 kB     00:00    
(2/2): gnome-autoar-0.4.3-1.fc35.x86_64.rpm                                                                                                                                                                                                     206 kB/s |  59 kB     00:00    
Total                                                                                                                                                                                                                                           244 kB/s | 209 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                                                                                        1/1 
  Reinstalling     : libuv-1:1.44.1-1.fc35.x86_64                                                                                                                                                                                                                           1/6 
  Reinstalling     : gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                                                                                                                                       2/6 
  Obsoleting       : libuv-1:1.43.0-2.fc35.x86_64                                                                                                                                                                                                                           3/6 
  Cleanup          : libuv-1:1.44.1-1.fc35.x86_64                                                                                                                                                                                                                           4/6 
  Obsoleting       : gnome-autoar-0.4.2-1.fc35.x86_64                                                                                                                                                                                                                       5/6 
  Cleanup          : gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                                                                                                                                       6/6 
  Running scriptlet: gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                                                                                                                                       6/6 
/sbin/ldconfig: File /lib64/ is empty, not checked.

/sbin/ldconfig: File /lib64/ is empty, not checked.

  Verifying        : gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                                                                                                                                       1/6 
  Verifying        : gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                                                                                                                                       2/6 
  Verifying        : gnome-autoar-0.4.2-1.fc35.x86_64                                                                                                                                                                                                                       3/6 
  Verifying        : libuv-1:1.44.1-1.fc35.x86_64                                                                                                                                                                                                                           4/6 
  Verifying        : libuv-1:1.44.1-1.fc35.x86_64                                                                                                                                                                                                                           5/6 
  Verifying        : libuv-1:1.43.0-2.fc35.x86_64                                                                                                                                                                                                                           6/6 

  gnome-autoar-0.4.3-1.fc35.x86_64                                                                                                         libuv-1:1.44.1-1.fc35.x86_64                                                                                                        

$ sudo ldconfig
ldconfig: File /lib64/ is empty, not checked.

@qulogic The problem with libnsl was resolved with the last update from Software Center.

$ sudo dnf history info last
Transaction ID : 119
Begin time     : Mon 21 Mar 2022 23:48:35 CET
Begin rpmdb    : 9af9d8431b69d07902dbdc400a63c3bacb726eed
End time       : Mon 21 Mar 2022 23:48:52 CET (17 seconds)
End rpmdb      : 452ca72b8fd45e1575daef55833eb2575abc90fb
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Upgrade  glib2-2.70.5-1.fc35.i686                   @updates
    Upgrade  glib2-2.70.5-1.fc35.x86_64                 @updates
    Upgrade  glib2-devel-2.70.5-1.fc35.x86_64           @updates
    Upgrade  glibc-2.34-29.fc35.i686                    @updates
    Upgrade  glibc-2.34-29.fc35.x86_64                  @updates
    Upgrade  glibc-all-langpacks-2.34-29.fc35.x86_64    @updates
    Upgrade  glibc-common-2.34-29.fc35.x86_64           @updates
    Upgrade  glibc-devel-2.34-29.fc35.x86_64            @updates
    Upgrade  glibc-gconv-extra-2.34-29.fc35.i686        @updates
    Upgrade  glibc-gconv-extra-2.34-29.fc35.x86_64      @updates
    Upgrade  glibc-headers-x86-2.34-29.fc35.noarch      @updates
    Upgrade  glibc-langpack-en-2.34-29.fc35.x86_64      @updates
    Upgrade  glibc-langpack-it-2.34-29.fc35.x86_64      @updates
    Upgrade  libnsl-2.34-29.fc35.i686                   @updates
    Upgrade  libnsl-2.34-29.fc35.x86_64                 @updates
    Upgrade  google-chrome-stable-99.0.4844.82-1.x86_64 @google-chrome
    Upgraded glib2-2.70.4-1.fc35.i686                   @@System
    Upgraded glib2-2.70.4-1.fc35.x86_64                 @@System
    Upgraded glib2-devel-2.70.4-1.fc35.x86_64           @@System
    Upgraded glibc-2.34-28.fc35.i686                    @@System
    Upgraded glibc-2.34-25.fc35.x86_64                  @@System
    Upgraded glibc-2.34-28.fc35.x86_64                  @@System
    Upgraded glibc-all-langpacks-2.34-25.fc35.x86_64    @@System
    Upgraded glibc-all-langpacks-2.34-28.fc35.x86_64    @@System
    Upgraded glibc-common-2.34-25.fc35.x86_64           @@System
    Upgraded glibc-common-2.34-28.fc35.x86_64           @@System
    Upgraded glibc-devel-2.34-25.fc35.x86_64            @@System
    Upgraded glibc-devel-2.34-28.fc35.x86_64            @@System
    Upgraded glibc-gconv-extra-2.34-28.fc35.i686        @@System
    Upgraded glibc-gconv-extra-2.34-25.fc35.x86_64      @@System
    Upgraded glibc-gconv-extra-2.34-28.fc35.x86_64      @@System
    Upgraded glibc-headers-x86-2.34-25.fc35.noarch      @@System
    Upgraded glibc-headers-x86-2.34-28.fc35.noarch      @@System
    Upgraded glibc-langpack-en-2.34-25.fc35.x86_64      @@System
    Upgraded glibc-langpack-en-2.34-28.fc35.x86_64      @@System
    Upgraded glibc-langpack-it-2.34-25.fc35.x86_64      @@System
    Upgraded glibc-langpack-it-2.34-28.fc35.x86_64      @@System
    Upgraded libnsl-2.34-28.fc35.i686                   @@System
    Upgraded libnsl-2.34-25.fc35.x86_64                 @@System
    Upgraded libnsl-2.34-28.fc35.x86_64                 @@System
    Upgraded google-chrome-stable-99.0.4844.74-1.x86_64 @@System
$ sudo ldconfig