Gnome Boxes: Windows 10 VM stuck in startup screen

Hello,
I am running different Gnome Boxes on my fedora laptop.
Everything worked fine after I tried to install WSL in one of my Windows 10 VMs.
After the install, I tried to reboot the machine and since then it has not been starting anymore.

Startup gets to the point, where the windows logo shows in the upper part of the screen.
In the lower part it would usually show a loading icon. This icon does not show up and the Windows logo stays there forever.

When I “force shutdown” the VM and try to restart it, it starts with “Preparing automatic repair” and then shows the “Troubleshoot” menu.

There I cannot really do a lot. Start-Up repair is not working, as well as restore.
I tried cloning the box and starting the clone, but that does not work either.

I doubt the issue is in the config of the box itself, because it is just a clone of other boxes that are working fine. I am quite sure it has something to do with the WSL installation. I think I need to revert the installation or change a setting to get it to run.

I do not really know how to proceed, any idea on how to fix this box is greatly appreciated!

It somehow fixed itself by using virt-manager instead of gnome-boxes…