Gnome Background image and Widget is unstable

Sometimes, for no reason, the background image of GNOME freezes like a fig.
I use Gnome 45.1 on Fedora 39 ( Workstation )

This has happened to me three times. My operating system is always up to date and I just updated it an hour ago.

And the problem of wechat windows in the GNOME menu :

In the image above, when I leave the windows alone in another page, it was displayed correctly.

Please help me to solve this problem.
This problem is not permanent and sometimes happens after logging into my user account. (3 times so far) :thinking:
is that BUG ? :no_mouth:
If it is a bug, where can I report similar bugs? I have come across a number of bugs and Problem in the GNOME desktop that I would like to report.

we really need additional information.

Please run the command inxi -Fzxx and post the output as preformatted text that you copy and paste using the </> button on the tool bar.

  Kernel: 6.5.11-300.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: 1: GDM 2: LightDM note: stopped Distro: Fedora release 39 (Thirty
  Type: Desktop Mobo: Gigabyte model: EP31-DS3L serial: <superuser required>
    BIOS: Award v: FDc date: 05/22/2009
  Info: quad core model: Intel Core2 Quad Q8400 bits: 64 type: MCP
    arch: Penryn rev: A cache: L1: 256 KiB L2: 4 MiB
  Speed (MHz): avg: 2000 high: 2001 max: 2000 cores: 1: 2000 2: 2001 3: 2000
    4: 2000 bogomips: 21332
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Device-1: NVIDIA GT218 [GeForce 210] vendor: XFX Pine driver: nouveau
    v: kernel arch: Tesla pcie: speed: 2.5 GT/s lanes: 16 ports: active: VGA-1
    empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:0a65 temp: 67.0 C
  Display: wayland server: v: 1.20.14 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: nouveau gpu: nouveau display-ID: 0
  Monitor-1: VGA-1 model: LG (GoldStar) W1952 res: 1440x900 dpi: 90
    diag: 481mm (18.9")
  API: OpenGL v: 3.3 vendor: mesa v: 23.2.1 glx-v: 1.4 es-v: 3.1
    direct-render: yes renderer: NVA8 device-ID: 10de:0a65 display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel NM10/ICH7 Family High Definition Audio
    vendor: Gigabyte GA-D525TUD driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:27d8
  Device-2: NVIDIA High Definition Audio vendor: XFX Pine
    driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0be3
  API: ALSA v: k6.5.11-300.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 476.94 GiB used: 93.08 GiB (19.5%)
  ID-1: /dev/sda vendor: Silicon Power model: SPCC Solid State Disk
    size: 476.94 GiB speed: <unknown> serial: <filter>
  ID-1: / size: 475.94 GiB used: 92.78 GiB (19.5%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 315.8 MiB (32.4%) fs: ext4
    dev: /dev/sda2
  ID-3: /home size: 475.94 GiB used: 92.78 GiB (19.5%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 3.81 GiB used: 594.5 MiB (15.2%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 91.0 C mobo: N/A gpu: nouveau temp: 67.0 C
  Fan Speeds (rpm): N/A
  Processes: 286 Uptime: 58m Memory: total: 4 GiB available: 3.81 GiB
  used: 1.97 GiB (51.8%) Init: systemd v: 254 target: graphical (5)
  default: graphical Compilers: gcc: 13.2.1 clang: 17.0.4 Packages: pm: rpm
  pkgs: N/A note: see --rpm pm: flatpak pkgs: 54 Shell: Bash v: 5.2.21
  running-in: gnome-terminal inxi: 3.3.31

I have left the computer on in this mode. If I reboot the computer, the problem is solved. (So far that is the only solution.)

It really looks like a video driver issue.

The Geforce 210 was released in 2009.
You have 4GB RAM
with a Core 2 Quad at 2000 MHz.

That system is seriously under powered for running F39 with Gnome and Wayland.

I think you can expect the performance you are getting or worse from that hardware and this version of fedora. Going forward it will only become worse as the machine continues to remain and the software is advancing for higher powered machines.

One thing that might help would be to bite the bullet and fall back to X11 instead of wayland, and at the same time install the appropriate drivers for that GPU (nvidia 340xx) from rpmfusion.

If I use X11, will the problem be solved?
I have no problem using X11

Do you have a solution for this problem?

No I don’t

There are no guarantees, but it certainly would not hurt to make the attempt. Having the problems you show in the images above would be enough incentive for me to try.

The worst that would likely happen would be no improvement and you decide to roll back to the current config. The best would be a full solution and good stability in the graphics.

It’s interesting that this happens sometimes, and I’ve yet to find a logical reason why it doesn’t always happen.

A basic question!
Are you sure this problem is due to lack of system resources?
So why didn’t I have such a problem in Fedora 38 or earlier?