Gnome 40 corrupted

Is it really corrupted? I have been using fedora 34 since it was available. It came with gnome 40 and it worked ok. Yesterday (8/10/2021) I noticed some programs had some issues. I have this launcher called albert.
It was running from the startup, but I couldn’t make it show using the keyboard shortcut or by any other means. I reinstall it several times and same effect.

I noticed some other different things, my display (2 of them) were not in the right order, I fixed them.
The minimize,maxime, close buttons are missing in some programs (i.e. Kitty the terminal).
I went to check the gnome extensions using Firefox and I saw some of them not enabled, even they were working. i.e. Applications menu and Arc Menu.
I tried to switch them on, but no sucess. I uninstall them and install them again.
They were removed from the top of my screen and since then I am not able to switch them ON. Sometimes when I tried to change a configuration gnome crashes and I have to log in again.
I think gnome is corrupted or something else causing my environment to cause issues.
I had the kitty font large, now it is small and I cannot make it as it was before.

Any ideas?

I used to use gnome-tweaks for extension management, but now that is handled by gnome-extensions-app