Garbled audio

Hello, when i am using applications that use sounds, or music, it becomes garbled.
A recording of the garbled audio: garbled.mp3 - Google Drive
I tried deleting speechdispatcher and restoring alsa using alsactl.
Here is my system info:
Fedora Linux 38 Workstation Edition (x86-64)
using cinnamon 5.8.4
kernel version 6.4.10-200.fc38.x86_64
processor: 12th Gen Intel© Core™ i5-12500H × 12
RAM: 15.3 GiB
527gb nvme ssd
I’m also using a 82UT Yoga Slim 7 Pro 14IAH7
Any help appreciated!

I actually have the same or similar problem on my Thinkpad P1 gen3, but only when playing games. I have a suspicion this could be a more general issue related to certain Intel audio chipsets, or similar. I wonder if anyone knows about some recent high-profile problems in this area.

$ lspci -nn | grep -i audio
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Comet Lake PCH cAVS [8086:06c8]

I also experience that on my 12th gen Intel laptop.
It’s been happening very frequently lately when playing Minecraft (an older version which probably also uses an older OpenAL version), when I also have any other application do audio things at the same time (e. g. Spotify).

Restarting the pipewire service restores the normal audio.

Thanks! This fixed the issue!

Hmm, I can’t reproduce it easily, it happens randomly, when it happened for me, I think restarting pipewire didn’t work. I had to exit the game and start it again. So perhaps my issue is different.

@firlaevhans @ollix27 It looks like your issue might be this one, here’s an example sound. If you can, please help with debugging in that ticket. Or file a different ticket against pipewire, if you think it’s a different problem. Thanks!

Yep, this is the exact same sound, i still get the issue sometimes and restarting doesn’t work now.

Same issue here, I get this consistently on zoom calls. I had a ticket open with them until one day it happened with firefox. There is a similar issue being tracked on arch. They think it’s a 6.4 kernel issue. I think it’s a pipewire issue. I needed reliable audio for work so I did the most unhelpful thing possible and switched to pulse audio. This seems to have helped me out.

The restarting works now.

Fedora 38, kept up to date, I’ve had the same issue for between one and two weeks. The audio works fine, and suddenly, it becomes garbled as described above.

I first thought my decades-old sound system was dying, but I found out the unplugging and replugging of the audio device to fix it, but only for some time. Sometimes for hours, sometimes for just a few minutes.

And since I was tired of it, I started using the embedded audio device on the laptop, where the same issue arose. So I knew it was a software bug.

Once I was able to restore the sound quality by just going to the Gnome sound settings, I think I just tested the audio channels (you know, “front left”, “front right”), I’m not sure, but I could never reproduce it anyway.

Trying to restart pipewire or wireplumber just led to complete silence, and I had to log out and back in to get audio again.

Oddly enough, it never happened with my Sony 3D Pulse headsets which are using a USB dongle. That’s the one I use for Zoom, so I can’t confirm the Zoom issue above.

$ lspci -nn | grep -i audio 
0000:00:1f.3 Multimedia audio controller [0401]: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller [8086:a0c8] (rev 20)

The sound system I regularly use is an audio jack from the monitor through a USB-C connection, and it doesn’t show in the list of PCI devices. The laptop itself (ASUSTeK COMPUTER INC. ZenBook UX363EA_UX371EA) doesn’t have a jack plug, and I don’t have another USB-C to jack adaptor to compare.


I also used the pulse 3d headset and it nullified the garbled audio.

In bug 2232584 there’s a test kernel which could resolve this problem:

Anyone affected, can you please try that kernel and post your feedback in that bugzilla or here, whether it seems to fix the problem on your hardware? Thanks!

I don’t know what I’m doing wrong but I can’t boot on that kernel.

Downloaded and installed kernel, kernel-core, kernel-modules, kernel-modules-core and kernel-modules-extra from the link above, but when I boot on that kernel, I get something along the lines of

bad shim signature
you need to load the kernel

and just coming back to the Grub menu.

Right. Since this is not an official Fedora build, you need to disable SecureBoot first. (Make sure to re-enable it once you’re back running official Fedora kernels).

A fix for garbled audio should also be included in the upcoming 6.4.12 kernel.

After disabling Secure Boot, and booting on that test kernel, I can happily report I could listen to music all day long with no issue!

The update hit bodhi with kernel-6.4.12-200.fc38 at Still needs some karma. I switched back to pipewire and updated the kernel using Installing Kernel from Koji :: Fedora Docs. So far, so good, but I haven’t had a full day of zoom meetings to verify it.